Select One or Other Not Working

1. What is the problem? Be very detailed.
I have some select_one or_other field type but when I test the form on the phone, am just getting the list with out the other option. What could be the issue here?
2. What app or server are you using and on what device and operating system? Include version numbers.
This is with ODK Collect and aggregate server. Using Android device to test the form
3. What you have you tried to fix the problem?
tried changing the or_other to caps but not working still
4. What steps can we take to reproduce the problem?
select_one main_hub or_other
select_one facility or_other

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Hi @Walusiku_Muyunda
could you attach your form. It's very difficult to tell what's wrong without it.

1 Like

sample.xlsx (16.2 KB)

Here is the sample form. Thank you

Hi @Grzesiek2010, di you manage to take a look at the form?

Not yet, I'll try this evening.

First of all your form is broken because there is no main_hub list of choices and I can't convert it. Please fix it.
What version of ODK Collect are you using?

sample.xlsx (16.1 KB) sample.xml (12.9 KB)

Please attached both xlsx and xml versions, I have removed the main_hub for easy detection.

Hello Walusiku Muyunda,

I had done some changes in Excel in the relevant. Please do check it , I had highlighted them in yellow. And its working perfectly right now.

Hope it works for you as well. Do tell me if it works or not.

Stay safe,

Regards,
Dinesh Dongol

sample.xlsx (15.7 KB)

Hi @Dnes_Dangol, my question was really on the type select_one facility or_other that does not seem to work. I expect the "other" option to be automatically provide once I added or_other to my field type, but this is not working. Than you for the attempt though.

@Grzesiek2010, the version is 2.0.3.