Sending finalized form

1. What is the problem? Be very detailed.
my field officer completed the form and saved but she could not see it in send finalized form but it is stored in view saved form.

2. What app or server are you using and on what device and operating system? Include version numbers.

3. What you have you tried to fix the problem?
tried checking if all the questions were answered and it was and all question are required
4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Hello @Dada,

Have you verified that the form was finalized?
A form is not finalized when all required questions are answered, but it should also be marked as such at in the last screen.

Alternatively, you should be able to activate the option to mark forms as finalized by default (conditionally on all answers being completed).

I hope this helps.


Hi Dada,

Maybe your field officer/s accidentaly activated the "auto send" function. You need to check ODK Collect settings on their devices with this following steps:
Open ODK Collect, go to "Admin Settings" -> "General Settings" -> "Form management" -> under the "form submission" area, make sure the "auto send" is "off".

I hope this work.


Thank you so much this was what happened. Mark as finalized was not ticked.

How can I automate it

Automate what? Could you elaborate?

How can I automate the mark as finalized so that the field officers do not unmark it.

  1. Make sure that the option Default to finalize is enabled in General Settings -> Form management
  2. In Admin Settings -> User Settings uncheck the Default to finalize option
  3. Change the admin password in Admin Settings -> Admin Password

Thanks to that the option will be enabled but no longer visible in general settings so your field officers won't be able to change it.