Setting up ODK Central on an Ubuntu 18.04 server

1. What is the problem? Be very detailed.
I have worked through the installation step upto the last step

2. What app or server are you using and on what device and operating system? Include version numbers.

I am installing on Ubuntu 18.04

3. What you have you tried to fix the problem?
I tried to create the folders manually, I also tried to run the "docker-compose up -d" as super user

4. What steps can we take to reproduce the problem?

Attempt to setup ODK Central on an Ubuntu 18.04 server

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

A screen shot

Hi @paul_macharia,

I think you should run docker-compose up -d as root user.
Here your are simply logged as pmacharia.

Thanks @mathieubossaert

I have tried to run docker-compose up -d as root but have the same error.

Could you try follow these steps: Installing ODK Central on Ubuntu VM into Azure

If you want to install into your own server or any other Virtual Machine, there are two important points you should pay attention.

  1. After installing Docker allow ports 2375 and 2376
  2. Install ODK Central Server using root user

Thanks @Odil,

I have installed docker and run all the other commands successfully.

The only command failing is the last command to start ODK Central.

Looks like there is write access permission issue with a folder in the /data folder.

I am a newbie in Ubuntu. I wish I could access the generated log file and review it. Any ideas?

Paul Macharia

Could you share log files or screen?

Hello @Odil,

Here's a screen shot.


Hmm, I could install it to DigitalOcean. Are you installing it into your own server?

Yes @Odil ,

I am installing on my own server.


Hey @Odil @mathieubossaert,

I hacked it!!

The problem was how I was installing docker-compose. Needed to run the following;
Run this command to download the current stable release of Docker Compose:

sudo curl -L "$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose


sudo chmod +x /usr/local/bin/docker-compose

final output is

Now working to get ODK Central accessed on a Web browser.

Thanks for the help.




I have been working this whole week to get my ODK Central setup accessible on a browser.

In my experience, working with a customssl could be the option for setting up ODK Central on a local box.

The main reason I kept working on the ODK Central setup is because of it visualization features and working with R. I will be playing around with ruODK in the next weeks and months to see how it could meet a number of use cases researchers and program people have been asking for in the past.

Now my ODK Central is online

Will keep you posted.



Hi, @paul_macharia.
Can you please share a summary of all the steps of setting up ODK Central on a local Ubuntu 18.04 server?
Thanks in advance.

1 Like

@Amal Definitely,

Much of this is already part of this thread.

  1. I used the ODK Central Documentation from here installing on Digitalocean.
  1. On setting up ssl, I used the documentation from here
  • I used existing .pem and the .key files from my custom domain.

All the best! Please share your experience.


1 Like

thanks for sharing this.
I will share my experience with pleasure.
Best regards,

1 Like


@Odil Thank you very much.
I am also trying to Set up ODK Central on an Ubuntu 16.4 Server at the amazon server
I installed instance ubuntu-xenial-16.04 as per installing-elsewhere Now i want to install docker.
I didn't get any step by step guide? it is inside the ubuntu 16.04 instance? how to do this? read steps provided for Digital occen but can not relate to Amazon ES server. Please guide me. How to install docker and after that ODK central?

Hi @kadam.sagar98, are you setting up a new Amazon EC2 server? Is there a reason you are using 16.04? It should be possible to pick a newer version of Ubuntu.

If you want to use 16.04, you can try following one of these instructions for setting up Docker:

Thank you for your reply. Finally, I want to set up ODK central on AWS server for my NGO. I do not know which one server and docker is good. As you suggested i will try a new one.

A post was split to a new topic: Trouble accessing Central from web