Submitted ODK Form not found in ODK Aggregate Server

What is the problem? Please be detailed.
Some forms sent successfully based on ODK Collect but was not found in the ODK Aggregate server.

What ODK tool and version are you using? And on what device and operating system version?
ODK Collect v1.11.0

What steps can we take to reproduce the problem?
It is intermittent and am not able to determine the cause.

What you have you tried to fix the problem?

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.
Is it possible to send again the saved/sent forms in the ODK Collect?

Dont painc you have all forms in your phone or tablet however you need to check whether gave access to anonymous user if yes might be someone else who knows URL he can delete forms

1 Like

Hi @Chinx. I'm assuming that this wasn't some malicious/inadvertent mistake of someone logging into the server and deleting the form. I'm also assuming that you didn't explicitly delete the submissions from the devices that collected the data.

With those above assumptions in mind, you need to do a little detective work so the community can help figure out what might have happened.

In Aggregate, under Submission Admin, select the form. Do you see any incomplete submissions? If so, that might explain the behavior you are seeing.

If you upload the submission, but fail to upload all media attachments, it places the submission in the incomplete submissions bucket. While it resides there, it won’t be published to external servers or downloadable via ODK Briefcase.
– https://docs.opendatakit.org/aggregate-use

Next, confirm that the forms were actually sent. In ODK Collect, from the Main Menu, go to View Sent Form. Under every saved form, you will see status (e.g., Finalized on Thu...). Confirm that the forms were actually sent.

If you do want to re-send the forms. You can do that in ODK Collect. From the Main Menu, go to Send Finalized Form, tap the Menu option (usually 3 vertical dots), then Change View, then Show Sent and Unsent Forms. Now you should be Select the forms you'd like and resend.

Try the above suggestions and report back with your findings!

1 Like

Hi @yanokwa,
I am facing this issue, I have encrypted forms which were sent to the server but doesn't show up on the server and now when I tried with your method , ODK collect shows the status of success while sending the form but on the Aggregate side it doesn't show up.. Please guide me how to fix this.

Thanks

@shaamuji Is it possible you put a submission_url in you form? If so, can you check to see if that is the same server you are checking?

Dear @yanokwa Thanks for the reply, I have already crossed the urls and server address, but the issue is still coming up, upon resending from changing view (sent and unsent forms) to same or different (test server), issue is coming again and again, please guide me to resolve this issue.

Thanks