Surveyors receiving the Could not find the resources you were looking for error message

1. What is the problem? Be very detailed.

Few of the surveyors are able to submit but few are receiving the error message "Could not find the resources you were looking for"

2. What app or server are you using and on what device and operating system? Include version numbers.

ODK Central with ODK Collect
client (v1.0.0)
server (v1.0.3)

3. What you have you tried to fix the problem?
Tried re-upload of the xlsx form. New entries are now able to submit but old pending entries are receiving the same error.

4. What steps can we take to reproduce the problem?
No idea on this

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Exact error message: "Form Name - Error: Generic Exception: Error: Could not find the resource you were looking for"

Resource not found generally means their app user doesn't have access to the form or the form they are submitting to has been closed or deleted.

Also, Central v1.0.0 is more than a year old. Upgrade to the latest Central (currently, v1.2.2) and see if you can reproduce this problem there.

Thanks @yanokwa

I'm afraid to upgrade central. Can you guide me the safe upgrade steps to avoid the data loss?

Here they are:
It's advisable to back up your data first.


Agreed. And has guidance on how to do that.