Trouble Installing

I'm having problems installing. I'm on a fresh-ish copy of Windows 7.
Have tried several times and not making it very far. I'm following
these instructions. http://developer.android.com/sdk/installing.html.
I haven't got very far.
I downloaded the Java stuff (JDK 6 Update 20) from here,
http://java.sun.com/javase/downloads/index.jsp. Then I tried
installing eclipse from here, http://www.eclipse.org/downloads/
(Eclipse Classic 3.5.2). I extracted it to C:\Program Files
(x86)\eclipse. When I tried running eclipse.exe I get a message that
it couldn't find javaw.exe.

So I went in and added the java bin to the path but when I run
eclipse.exe I am still getting the "I can't find javaw.exe" message.
Any help would be appreciated.

I'm having problems installing. I'm on a fresh-ish copy of Windows 7.
Have tried several times and not making it very far. I'm following
these instructions. http://developer.android.com/sdk/installing.html.
I haven't got very far.
I downloaded the Java stuff (JDK 6 Update 20) from here,
http://java.sun.com/javase/downloads/index.jsp. Then I tried
installing eclipse from here, http://www.eclipse.org/downloads/
(Eclipse Classic 3.5.2). I extracted it to C:\Program Files
(x86)\eclipse. When I tried running eclipse.exe I get a message that
it couldn't find javaw.exe.

So I went in and added the java bin to the path but when I run
eclipse.exe I am still getting the "I can't find javaw.exe" message.
Any help would be appreciated.

Hmm, weird. But anyways, look at the eclipse.ini file in the main Eclipse
dir. Check the '-vm' parameter; it should point to the javaw.exe in
C:\program files\Java\jdk1.6_20\bin or whatever.

Check these blog posts for a (much) clearer explanation:

··· On Thu, May 27, 2010 at 2:16 AM, wakewatcher wrote: - http://stackoverflow.com/questions/905611/how-do-i-set-eclipse-ini-vm-option

not a windows 7 person myself, but try extracting eclipse into your
desktop and see if that works. there may be windows uac issues that
you are running into...

··· On Wed, May 26, 2010 at 23:46, Karl Pietrzak wrote: > On Thu, May 27, 2010 at 2:16 AM, wakewatcher wrote: >> >> I'm having problems installing. I'm on a fresh-ish copy of Windows 7. >> Have tried several times and not making it very far. I'm following >> these instructions. http://developer.android.com/sdk/installing.html. >> I haven't got very far. >> I downloaded the Java stuff (JDK 6 Update 20) from here, >> http://java.sun.com/javase/downloads/index.jsp. Then I tried >> installing eclipse from here, http://www.eclipse.org/downloads/ >> (Eclipse Classic 3.5.2). I extracted it to C:\Program Files >> (x86)\eclipse. When I tried running eclipse.exe I get a message that >> it couldn't find javaw.exe. >> >> So I went in and added the java bin to the path but when I run >> eclipse.exe I am still getting the "I can't find javaw.exe" message. >> Any help would be appreciated. > > Hmm, weird. But anyways, look at the eclipse.ini file in the main Eclipse > dir. Check the '-vm' parameter; it should point to the javaw.exe in > C:\program files\Java\jdk1.6_20\bin or whatever. > Check these blog posts for a (much) clearer explanation: > > http://tonymcneil.wordpress.com/2008/03/26/eclipseini-vm-option/ > http://stackoverflow.com/questions/905611/how-do-i-set-eclipse-ini-vm-option >

Thanks for that. Got me a centimeter closer I suppose. So I set the
VM parameter to point to javaw.exe (However I thought that was the
point of putting it in the Windows PATH variable. Now when I execute
eclipse it I get this -> http://screencast.com/t/MTEzYTQ3ND and I get
this -> http://screencast.com/t/NTFiNjY2YTUt
When I click OK it all just disappears. Argghhh....

··· On May 26, 11:46 pm, Karl Pietrzak wrote: > On Thu, May 27, 2010 at 2:16 AM, wakewatcher wrote: > > > I'm having problems installing. I'm on a fresh-ish copy of Windows 7. > > Have tried several times and not making it very far. I'm following > > these instructions.http://developer.android.com/sdk/installing.html. > > I haven't got very far. > > I downloaded the Java stuff (JDK 6 Update 20) from here, > >http://java.sun.com/javase/downloads/index.jsp. Then I tried > > installing eclipse from here,http://www.eclipse.org/downloads/ > > (Eclipse Classic 3.5.2). I extracted it to C:\Program Files > > (x86)\eclipse. When I tried running eclipse.exe I get a message that > > it couldn't find javaw.exe. > > > So I went in and added the java bin to the path but when I run > > eclipse.exe I am still getting the "I can't find javaw.exe" message. > > Any help would be appreciated. > > Hmm, weird. But anyways, look at the eclipse.ini file in the main Eclipse > dir. Check the '-vm' parameter; it should point to the javaw.exe in > C:\program files\Java\jdk1.6_20\bin or whatever. > > Check these blog posts for a (much) clearer explanation: > > -http://tonymcneil.wordpress.com/2008/03/26/eclipseini-vm-option/ > - > http://stackoverflow.com/questions/905611/how-do-i-set-eclipse-ini-vm...

Thanks for that. Got me a centimeter closer I suppose. So I set the
VM parameter to point to javaw.exe (However I thought that was the
point of putting it in the Windows PATH variable

Hmmm, no, that doesn't found right. The JDK installation should put the
java.exe/javaw.exe from the JRE in the PATH. Have you modified it manually?

Now when I execute
eclipse it I get this -> http://screencast.com/t/MTEzYTQ3ND and I get
this -> http://screencast.com/t/NTFiNjY2YTUt
When I click OK it all just disappears. Argghhh....

The '-vm' variable looks completely wrong. What is your eclipse.ini?
Please attach it. Remember: it has to point to the javaw.exe in your JDK,
like the links I sent.

··· On Thu, May 27, 2010 at 10:12 PM, wakewatcher wrote:

Have you also defined a JAVA_HOME environment variable to point to the
parent folder to the bin directory?

e.g., C:\Program Files\Java\jdk1.6.0_20

If you define JAVA_HOME and have %JAVA_HOME%\bin in your PATH variable, that
should be all you need.

Mitch

··· On Thu, May 27, 2010 at 7:16 PM, Karl Pietrzak wrote:

On Thu, May 27, 2010 at 10:12 PM, wakewatcher steve.roberts@gmail.comwrote:

Thanks for that. Got me a centimeter closer I suppose. So I set the
VM parameter to point to javaw.exe (However I thought that was the
point of putting it in the Windows PATH variable

Hmmm, no, that doesn't found right. The JDK installation should put the
java.exe/javaw.exe from the JRE in the PATH. Have you modified it manually?

Now when I execute
eclipse it I get this -> http://screencast.com/t/MTEzYTQ3ND and I get
this -> http://screencast.com/t/NTFiNjY2YTUt
When I click OK it all just disappears. Argghhh....

The '-vm' variable looks completely wrong. What is your eclipse.ini?
Please attach it. Remember: it has to point to the javaw.exe in your JDK,
like the links I sent.