Unable to access Edit Submission Feature in ODK Central v1.2

1. What is the problem? Be very detailed.

Release of ODK Central V1.2 is a big news, which excited me to a great extent. The long awaited Edit Submission feature is said to be added. I have updated my central to v1.2, However, I am unable to find how can I edit any submission.

2. What app or server are you using and on what device and operating system? Include version numbers.
ODK Central V1.2

3. What you have you tried to fix the problem?
I have viewed previous submissions (received before version change), then I have added a new form and created submissions. But somehow, I am unable to access that feature. I will be highly obliged if someone can guide on where to access that?
It will be great if a screenshot may be shared about the process. I was hoping to just have an edit submission feature at the start of each submission row.

Just Refreshing the Page has resolved the Issue. Sound silly, but worked. Bravo!!

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.


Just Refreshing the page after sometime, resolved the issue. Thanks a log to ODK team for a big feature and high value upgrade.

1 Like