Unable to export data to excel/csv

1. What is the problem? Be very detailed.
I have local ODK Server setup (formhub fork) that has been running well until 2 weeks back when it can't export data submission to excel or csv. See my screen shot below.

2. What app or server are you using and on what device and operating system? Include version numbers.
This is a formhub fork running: pybamboo==, pytz==2014.7, Django>=1.6,<1.7, django-guardian==1.2.4, django-registration-redux==1.1, django-templated-email==0.4.9, data==2.0.18
httplib2==0.9, mock==1.0.1, httmock==1.2.2, modilabs-python-utils==0.1.5,Pillow==2.5.3, poster==0.8.1, psycopg2==2.8.3, pymongo==2.7.2, lxml==3.4.0, django-nose==1.4.2, pandas==0.20.3,pyxform, South==1.0,django-reversion==1.8.4,xlrd==1.1.0,xlwt==0.7.5, openpyxl==2.0.5,celery==3.1.23,django-celery==3.1.17,librabbitmq==1.5.2,python-digest==1.7
django-digest==1.13, j2xclient,requests==2.4.1,elaphe==0.5.6,dict2xml==1.3, djangorestframework==2.4.3, djangorestframework-csv==1.3.3, django-cors-headers==0.13, Markdown==2.5,django-filter==0.7, recaptcha-client==1.0.6, unicodecsv>=0.14.1, dpath==1.2-70, django-taggit==0.12.1, django-oauth-toolkit==0.7.2, savReaderWriter, jsonfield<1.0, django-db-readonly==0.3.2, , pylibmc==1.3.0, kombu==3.0.35, billiard==

3. What you have you tried to fix the problem?
Yes i have tried to restart the celeryd and its running well.
4. What steps can we take to reproduce the problem?
When you click to export in excel/csv it keep telling 'Pending ... Click to refresh' or 'Refreshing'
5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Apache error log
File "/opt/formshare/lib/python2.7/site-packages/django/db/backends/init.py", line 499, in validate_thread_sharing
% (self.alias, self._thread_ident, thread.get_ident()))
DatabaseError: DatabaseWrapper objects created in a thread can only be used in that same thread. The object with alias 'default' was created in thread id 139738191816448 and this is thread id 139738242172672.