Unable to log into ODK aggregate

Hi,

I'm using ODK Aggregate v1.0 beta rev. 3 windows-installer to create MySQL
and tomcat instances

I'm able to install all the required software's, when I'm trying to log in
the gmail account, i'm getting following error

http://localhost:8080/ODKAggregate/j_spring_openid_security_check
HTTP Status 401 - Authentication Failed: Unable to process claimed identity
'https://www.google.com/accounts/o8/id'

also attached the tomcat logs, kindly help to resolve this

Thanks
S

catalina.2011-07-28.log (48.9 KB)

The logs look normal. I believe this is a failure on the Google OpenID
login side of things.

Just to double-check -- it is fine to use "localhost" when accessing the
server running on your computer, but you should not type in "localhost" (or
127.0.0.1) as the fully-qualified hostname of your computer when
configuring/installing ODKAggregate. The install script will populate the
fully-qualified hostname field with a suitable value if you are unsure of
what to enter (it will use your IP address if it can't find anything
suitable; that's fine).

To debug your issue, first, if you're using Gmail, open a browser window and
open that gmail account (e.g., so you can read e-mail).
Otherwise, if you're using a Google apps account, it will only work if
Google maintains the authoritative user account list for your organization.
If during the login process to Google Apps you get redirected away from
Google, then you'll need to change to use a Gmail super-user e-mail account
(and reconfigure ODK Aggregate to recognize that account as its superuser
email account). If you didn't get redirected away from Google during the
login process, you're fine. This ensures that the email account used during
the Google OpenID login process will be the one you intended to use. If you
have multiple Gmail or Google Apps accounts, the OpenID login process will
otherwise automatically use whichever one you last logged in with, and that
may not be the one you intended to use.

Keep the browser open.

Now, stop and restart the Apache Tomcat webserver.

Open a browser window to your ODKAggregate site (e.g.,
http://localhost:8080/ODKAggregate).

Choose to log in with Google OpenID.

You should get a web page from Google asking whether you want to allow your
ODK Aggregate webserver to obtain your e-mail address.

You must Allow this.

At that point, you should be returned to
http://localhost:8080/ODKAggregate/Aggregate.html, and should see the main
webpage of the webserver.

··· ------- Mitch

On Thu, Jul 28, 2011 at 2:56 AM, ODK Tools odk.tools@gmail.com wrote:

Hi,

I'm using ODK Aggregate v1.0 beta rev. 3 windows-installer to create MySQL
and tomcat instances

I'm able to install all the required software's, when I'm trying to log in
the gmail account, i'm getting following error

http://localhost:8080/ODKAggregate/j_spring_openid_security_check
HTTP Status 401 - Authentication Failed: Unable to process claimed identity
'https://www.google.com/accounts/o8/id'

also attached the tomcat logs, kindly help to resolve this

Thanks
S

--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en

--
Mitch Sundt
Software Engineer


University of Washington
mitchellsundt@gmail.com

Hi Mitch,

Thank you for the response..
Can you guide me how to sign in with Aggregate password / Anonymous
access?
Still i was unable to sign in with google account.

Kind Regards
S

··· On Jul 28, 10:01 pm, Mitch Sundt wrote: > The logs look normal. I believe this is a failure on the Google OpenID > login side of things. > > Just to double-check -- it is fine to use "localhost" when accessing the > server running on your computer, but you should not type in "localhost" (or > 127.0.0.1) as the fully-qualified hostname of your computer when > configuring/installing ODKAggregate. The install script will populate the > fully-qualified hostname field with a suitable value if you are unsure of > what to enter (it will use your IP address if it can't find anything > suitable; that's fine). > > To debug your issue, first, if you're using Gmail, open a browser window and > open that gmail account (e.g., so you can read e-mail). > Otherwise, if you're using a Google apps account, it will only work if > Google maintains the authoritative user account list for your organization. > If during the login process to Google Apps you get redirected away from > Google, then you'll need to change to use a Gmail super-user e-mail account > (and reconfigure ODK Aggregate to recognize that account as its superuser > email account). If you didn't get redirected away from Google during the > login process, you're fine. This ensures that the email account used during > the Google OpenID login process will be the one you intended to use. If you > have multiple Gmail or Google Apps accounts, the OpenID login process will > otherwise automatically use whichever one you last logged in with, and that > may not be the one you intended to use. > > Keep the browser open. > > Now, stop and restart the Apache Tomcat webserver. > > Open a browser window to your ODKAggregate site (e.g.,http://localhost:8080/ODKAggregate). > > Choose to log in with Google OpenID. > > You should get a web page from Google asking whether you want to allow your > ODK Aggregate webserver to obtain your e-mail address. > > You must Allow this. > > At that point, you should be returned tohttp://localhost:8080/ODKAggregate/Aggregate.html, and should see the main > webpage of the webserver. > > ------- > Mitch > > > > > > > > > > On Thu, Jul 28, 2011 at 2:56 AM, ODK Tools wrote: > > Hi, > > > I'm using ODK Aggregate v1.0 beta rev. 3 windows-installer to create MySQL > > and tomcat instances > > > I'm able to install all the required software's, when I'm trying to log in > > the gmail account, i'm getting following error > > >http://localhost:8080/ODKAggregate/j_spring_openid_security_check > > HTTP Status 401 - Authentication Failed: Unable to process claimed identity > > 'https://www.google.com/accounts/o8/id' > > > also attached the tomcat logs, kindly help to resolve this > > > Thanks > > S > > > -- > > Post: opendatakit@googlegroups.com > > Unsubscribe: opendatakit+unsubscribe@googlegroups.com > > Options:http://groups.google.com/group/opendatakit?hl=en > > -- > Mitch Sundt > Software Engineerhttp://www.OpenDataKit.org > University of Washington > mitchellsu...@gmail.com

When first deployed, Aggregate 1.0 will only allow the super-user to log in
(using Google OpenID).
Once you're logged in as that super-user, you can configure it to allow
anonymous access
or to log in with a local account and password that you set up.

But first, you need to log in as that super-user.

One quick thing to double-check is that the super-user e-mail is your email
(e.g., odk.tools@gmail.com) and doesn't have any trailing or leading
spaces.

I do this on Windows by installing and using 7-Zip ( http://www.7-zip.org/).

Select the "ODKAggregate.war", right-click, 7-zip / Open archive.
Navigate within the 7-Zip folder view to
WEB-INF\lib\ODKAggregate-settings.jar (right-click, Open).
Double-click on security.properties Choose to open this with Notepad (or an
editor of your choice).

Toward the bottom of this file, you should see:

This is configured during install. If blank, discovers an IP address

security.server.hostname=mitch.cs.washington.edu

··· # # any port pairings can be used. security.server.port=8080 security.server.securePort=8443

e-mail of designated superuser. This must be a user that has an OpenID

login hosted by a remote server (i.e., this must be a gmail account).

this should be of the form: 'mailto:user@gmail.com'

security.server.superUser=mailto:mitchellsundt@gmail.com

Double-check that the last entry (security.server.superUser) has no typos or
trailing spaces in it.
e.g., for you, it should read: security.server.superUser=mailto:
odk.tools@gmail.com

Double-check that the security.server.hostname is correct, is not
"localhost" or "127.0.0.1",
and has no leading or trailing spaces.

Double-check that the security.server.port is the port that the webserver is
using (e.g., 8080).
The security.server.securePort is only used if you have an SSL certificate
and can be otherwise ignored.

If any of these are incorrect, you will need to re-run the installer to make
the correction.

After making the change, be sure to copy the updated ODKAggregate.war to the

/webapps directory of your Tomcat server to deploy the change.

Mitch

On Fri, Jul 29, 2011 at 12:24 AM, ODK Tools odk.tools@gmail.com wrote:

Hi Mitch,

Thank you for the response..
Can you guide me how to sign in with Aggregate password / Anonymous
access?
Still i was unable to sign in with google account.

Kind Regards
S

On Jul 28, 10:01 pm, Mitch Sundt msu...@cs.washington.edu wrote:

The logs look normal. I believe this is a failure on the Google OpenID
login side of things.

Just to double-check -- it is fine to use "localhost" when accessing the
server running on your computer, but you should not type in "localhost"
(or
127.0.0.1) as the fully-qualified hostname of your computer when
configuring/installing ODKAggregate. The install script will populate
the
fully-qualified hostname field with a suitable value if you are unsure of
what to enter (it will use your IP address if it can't find anything
suitable; that's fine).

To debug your issue, first, if you're using Gmail, open a browser window
and
open that gmail account (e.g., so you can read e-mail).
Otherwise, if you're using a Google apps account, it will only work if
Google maintains the authoritative user account list for your
organization.
If during the login process to Google Apps you get redirected away from
Google, then you'll need to change to use a Gmail super-user e-mail
account
(and reconfigure ODK Aggregate to recognize that account as its superuser
email account). If you didn't get redirected away from Google during the
login process, you're fine. This ensures that the email account used
during
the Google OpenID login process will be the one you intended to use. If
you
have multiple Gmail or Google Apps accounts, the OpenID login process
will
otherwise automatically use whichever one you last logged in with, and
that
may not be the one you intended to use.

Keep the browser open.

Now, stop and restart the Apache Tomcat webserver.

Open a browser window to your ODKAggregate site (e.g.,
http://localhost:8080/ODKAggregate).

Choose to log in with Google OpenID.

You should get a web page from Google asking whether you want to allow
your
ODK Aggregate webserver to obtain your e-mail address.

You must Allow this.

At that point, you should be returned
tohttp://localhost:8080/ODKAggregate/Aggregate.html, and should see the main
webpage of the webserver.


Mitch

On Thu, Jul 28, 2011 at 2:56 AM, ODK Tools odk.to...@gmail.com wrote:

Hi,

I'm using ODK Aggregate v1.0 beta rev. 3 windows-installer to create
MySQL

and tomcat instances

I'm able to install all the required software's, when I'm trying to log
in

the gmail account, i'm getting following error

http://localhost:8080/ODKAggregate/j_spring_openid_security_check
HTTP Status 401 - Authentication Failed: Unable to process claimed
identity

'https://www.google.com/accounts/o8/id'

also attached the tomcat logs, kindly help to resolve this

Thanks
S

--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options:http://groups.google.com/group/opendatakit?hl=en

--
Mitch Sundt
Software Engineerhttp://www.OpenDataKit.org
University of Washington
mitchellsu...@gmail.com

--
Post: opendatakit@googlegroups.com
Unsubscribe: opendatakit+unsubscribe@googlegroups.com
Options: http://groups.google.com/group/opendatakit?hl=en

--
Mitch Sundt
Software Engineer


University of Washington
mitchellsundt@gmail.com

Hi Mitch,

I have checked for trailing spaces, even though there is no luck :frowning:
Do you feel is firewall or proxy makes any issues?

Kind Regards,
S

··· On Jul 29, 11:08 pm, Mitch Sundt wrote: > When first deployed, Aggregate 1.0 will only allow the super-user to log in > (using Google OpenID). > Once you're logged in as that super-user, you can configure it to allow > anonymous access > or to log in with a local account and password that you set up. > > But first, you need to log in as that super-user. > > One quick thing to double-check is that the super-user e-mail is your email > (e.g., odk.to...@gmail.com) and doesn't have any trailing or leading > spaces. > > I do this on Windows by installing and using 7-Zip (http://www.7-zip.org/). > > Select the "ODKAggregate.war", right-click, 7-zip / Open archive. > Navigate within the 7-Zip folder view to > WEB-INF\lib\ODKAggregate-settings.jar (right-click, Open). > Double-click on security.properties Choose to open this with Notepad (or an > editor of your choice). > > Toward the bottom of this file, you should see: > > # This is configured during install. If blank, discovers an IP address > security.server.hostname=mitch.cs.washington.edu > # > # any port pairings can be used. > security.server.port=8080 > security.server.securePort=8443 > > # e-mail of designated superuser. This must be a user that has an OpenID > # login hosted by a remote server (i.e., this must be a gmail account). > # this should be of the form: 'mailto:u...@gmail.com' > security.server.superUser=mailto:mitchellsu...@gmail.com > > Double-check that the last entry (security.server.superUser) has no typos or > trailing spaces in it. > e.g., for you, it should read: security.server.superUser=mailto: > odk.to...@gmail.com > > Double-check that the security.server.hostname is correct, is not > "localhost" or "127.0.0.1", > and has no leading or trailing spaces. > > Double-check that the security.server.port is the port that the webserver is > using (e.g., 8080). > The security.server.securePort is only used if you have an SSL certificate > and can be otherwise ignored. > > If any of these are incorrect, you will need to re-run the installer to make > the correction. > > After making the change, be sure to copy the updated ODKAggregate.war to the > > /webapps directory of your Tomcat server to deploy the change. > > Mitch > > > > > > > > > > On Fri, Jul 29, 2011 at 12:24 AM, ODK Tools wrote: > > Hi Mitch, > > > Thank you for the response.. > > Can you guide me how to sign in with Aggregate password / Anonymous > > access? > > Still i was unable to sign in with google account. > > > Kind Regards > > S > > > On Jul 28, 10:01 pm, Mitch Sundt wrote: > > > The logs look normal. I believe this is a failure on the Google OpenID > > > login side of things. > > > > Just to double-check -- it is fine to use "localhost" when accessing the > > > server running on your computer, but you should not type in "localhost" > > (or > > > 127.0.0.1) as the fully-qualified hostname of your computer when > > > configuring/installing ODKAggregate. The install script will populate > > the > > > fully-qualified hostname field with a suitable value if you are unsure of > > > what to enter (it will use your IP address if it can't find anything > > > suitable; that's fine). > > > > To debug your issue, first, if you're using Gmail, open a browser window > > and > > > open that gmail account (e.g., so you can read e-mail). > > > Otherwise, if you're using a Google apps account, it will only work if > > > Google maintains the authoritative user account list for your > > organization. > > > If during the login process to Google Apps you get redirected away from > > > Google, then you'll need to change to use a Gmail super-user e-mail > > account > > > (and reconfigure ODK Aggregate to recognize that account as its superuser > > > email account). If you didn't get redirected away from Google during the > > > login process, you're fine. This ensures that the email account used > > during > > > the Google OpenID login process will be the one you intended to use. If > > you > > > have multiple Gmail or Google Apps accounts, the OpenID login process > > will > > > otherwise automatically use whichever one you last logged in with, and > > that > > > may not be the one you intended to use. > > > > Keep the browser open. > > > > Now, stop and restart the Apache Tomcat webserver. > > > > Open a browser window to your ODKAggregate site (e.g., > >http://localhost:8080/ODKAggregate). > > > > Choose to log in with Google OpenID. > > > > You should get a web page from Google asking whether you want to allow > > your > > > ODK Aggregate webserver to obtain your e-mail address. > > > > You must Allow this. > > > > At that point, you should be returned > > tohttp://localhost:8080/ODKAggregate/Aggregate.html, and should see the main > > > webpage of the webserver. > > > > ------- > > > Mitch > > > > On Thu, Jul 28, 2011 at 2:56 AM, ODK Tools wrote: > > > > Hi, > > > > > I'm using ODK Aggregate v1.0 beta rev. 3 windows-installer to create > > MySQL > > > > and tomcat instances > > > > > I'm able to install all the required software's, when I'm trying to log > > in > > > > the gmail account, i'm getting following error > > > > >http://localhost:8080/ODKAggregate/j_spring_openid_security_check > > > > HTTP Status 401 - Authentication Failed: Unable to process claimed > > identity > > > > 'https://www.google.com/accounts/o8/id' > > > > > also attached the tomcat logs, kindly help to resolve this > > > > > Thanks > > > > S > > > > > -- > > > > Post: opendatakit@googlegroups.com > > > > Unsubscribe: opendatakit+unsubscribe@googlegroups.com > > > > Options:http://groups.google.com/group/opendatakit?hl=en > > > > -- > > > Mitch Sundt > > > Software Engineerhttp://www.OpenDataKit.org > > > University of Washington > > > mitchellsu...@gmail.com > > > -- > > Post: opendatakit@googlegroups.com > > Unsubscribe: opendatakit+unsubscribe@googlegroups.com > > Options:http://groups.google.com/group/opendatakit?hl=en > > -- > Mitch Sundt > Software Engineerhttp://www.OpenDataKit.org > University of Washington > mitchellsu...@gmail.com