Unable to pull a form with nested repeat count values using Briefcase

What is the problem? Please be detailed.
I have an .xls form with two nested repeat constructs. The second one ends according to the value entered in a previous question. When I upload the corresponding .xml form into Aggregate on GAE everything works fine. I also need to synchronize data periodically with my local machine where Aggregate runs with Tomcat8 and MySql so that I can interact with the database in a more advanced way (i.e. by connecting a statistic tool such as R-project). In order to do this I use Briefcase. All forms work fine except for the above-mentioned one! Briefcase gives me the following error: "Fetching form definition resolving against briefcase form definitions Error parsing form definition: org.opendatakit.aggregate.exception.ODKIncompleteSubmissionData: Javarosa failed to construct a FormDef. Is this an XForm definition?"
Hope you can help me. Thank you very much!

What ODK tool and version are you using? And on what device and operating system version?
I am using Aggregate 1.4.15 on GAE as main storage system. I also deployed Aggregate 1.4.15 to Tomcat 8 and MySql 5.7.24 on my local machine with Ubuntu 16.04. I am using Briefcase 1.13.1 to synchronize data between the two Aggregate deployments. I am also using XLSForm Online to convert xls forms.

What steps can we take to reproduce the problem?
You can upload the two attached xls forms on Aggregate and try to pull them using Briefcase

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.
The following information could help:

  • if I remove the repeat count value from the second repeat construct (which is the nested one) it works, but this way I'll have to add groups manually during the survey and this is not very practical;
  • the form has a complex constraint to avoid duplication of entries which seems to work only if I use nested groups (not sure if this is pertinent);
  • Until twenty days ago I was still using Aggregate 1.4.15 and I could not even upload the form on GAE as I got the same error. After upgrading to 1.7.1 I sorted out the issue, but when I pull the form with Briefcase it still doesn't work;
  • When I was using exactly the same form in July 2018 with Aggregate 1.4.15 and Briefcase 1.9.0 I didn't have this problem and everything used to work perfectly;
  • I attached two sample forms which reproduce the problem: test1 is the one that has the repeat count value and I am not able to pull with Briefcase; test2 which is the one that works fine (with no repeat count value).
    test1.xls (10.5 KB)
    test2.xls (10.5 KB)

Hello! Can anybody answer my question please? :thinking:

Hi @scampus!
I was trying to reproduce the issue but unfortunately, I was not able to. Everything worked just fine for me. I am using Aggregate 1.7.1 on Tomcat 8 and Briefcase 1.13.1 and odk xls to xml converter. The only thing that I can think of is that it can be connected to your storage directory. Did you try to pull the form into a completely new sd folder? I would recommend clearing prefs, set a new storage directory and trying to pull the form again.


Hi @kkrawczyk123,
thanks a lot for your reply and for spending time with my issue. I had already changed the storage directory but I didn't clear prefs and that was it! Now it works fine. Cheers!