Unexpected behaviour when attempting to open odkbuild file

I've created a small test survey using odkbuild x64 0.3.3.

The form would not upload to Aggregate (internet connection queried but in fact working well) so I successfully saved it in XML, XLS and odkbuild formats then closed and reopened Build in the hope uploading would be permitted.

Now the saved odkbuild file will not load in Build! Advice is to check it's accessible and valid.

I been through the same process a second time, just to ensure I didn't do anything too obviously stupid, but the result has been identical.

Any ideas as to what I can check to establish what is causing the problem of both refused uploading and inability to load a odkbuild file.


One thing which seems strange is the form_title within settings in the XLS saved file reads Untitled Form although I ensured the title was changed to a customised name prior to saving the xls file to my desktop.


Built identical survey by logging into web Build. Saved all three formats to desktop. Form_title reads correct customised name within xls and odkbuild will load into offline Build. Attempting to export to XLSForm within online Build fails however. Could Windows Defender require ports opening?

I've succesfully checked latest form created in online Build runs as expected in Collect.

Hi panthonyl; sorry about the delay in reply. Is there any chance you can attach the .odkbuild file here for me to take a look at?

Hi Clint,

No problem, thanks for picking this up.

I've stuck in Wetransfer.


If you need anything else let me know.



Hm. This is strange, I am able to open it just fine in Build. Any chance you can give the latest prerelease version a try?

Strangeness continues.

Steps taken.

  1. Load various saved odkbuild forms into web Build: All load successfully.
  2. Load same saved odkbuild forms into Build 0.3.3: All fail to load.
  3. Load same saved odkbuild forms into Build 0.3.4: All fail to load
  4. Switch PC
  5. Load same odkbuild forms into Build 0.3.4: All load successfully.
  6. Test whether export to XLSForm works: Confirmed working.

Both PC's running Win 10 Pro - 1709 - 16299.248

Looks like something creepy is going on with one of my PC's - would of course be my main PC that's playing up.

This loading issue is, for me, incidental to my main problem, especially now I can swap between PCs. My goal is to tweak the XLSForm to test out Relevant conditions. Converting XLSForms is therefore where I'm now truly stuck.

Sticking with PC 2 I undertook the following steps.

  1. Open saved XLSForm, make single change to Label cell (purely for test purposes), saved and closed file.

  2. Upoad file using ODK online converter

  3. Error returned:
    Error: ODK Validate Errors: XForm Parse Error: Encountered a problem with display condition for node [${comments}] at line: (), Bad node: org.javarosa.xpath.parser.ast.ASTNodeAbstractExpr@515f550a >> XForm is invalid. See above for the errors. org.javarosa.xform.parse.XFormParseException: Encountered a problem with display condition for node [${comments}] at line: (), Bad node: org.javarosa.xpath.parser.ast.ASTNodeAbstractExpr@515f550a Result: Invalid

  4. Same result using Nafundi converter with 1d3411d expression.

  5. Tried non-amended XLSForm directly after exporting to desktop: Same problems.

So, a smorgasbord of minor issues. Having said I'm absolutely delighted to have stumbled across this really neat piece of open-source software. Just purchased a couple of very cheap 7" tablets to complete a serious improvement in our survey taking.

Keep up the good work.



Quick update.

PC 2 is now failing to export XLSForms, displaying "Something went wrong" message.

On the plus side I've more or less worked out the answer, for which I thought I'd need access to the spreadsheet to resolve, so this issue is not causing me any lost time.