Upgrade ODK Central 1.2.1 to 1.3

1. What is the problem? Be very detailed.

I am following this guide here https://docs.getodk.org/central-upgrade/

When I try to "git pull" I gives me this

"hint: Fix them up in the work tree, and then use 'git add/rm '
hint: as appropriate to mark resolution and make a commit."

2. What app or server are you using and on what device and operating system? Include version numbers.

Using Linux Ubuntu 18.4. ODK Central 1.2.1

Docker version "docker-compose version 1.29.2, build 5becea4c"

3. What you have you tried to fix the problem?

So I tried the

" mv .env env-tmp
git pull
mv env-tmp .env"

Still does not work

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

I install this ODK central using the instructions for installing on Digital Ocean. It was an old version I started with I think 1 but then I upgraded like 3 months ago and it was upgraded to 1.2.1. So now I am trying to upgrade to version 1.3

Hi there @Nomeneta_Saili,
Sorry about your issue. Let's try this out and see if it will be enough to get you on your merry way to installing the greatest version of Central yet.

You can begin by manually copying your local .env file to a directory outside central. You can try

cp .env ~/Desktop/env-bak/.env

Next stop, try

git reset --hard HEAD

then hit it with the trusty old

git pull

Be sure to copy your .env file stashed away back to your central directory( cp ~/Desktop/env-bak/.env .env ) before proceeding. You can do a git stash pop afterwards just to be sure and continue with the rest of the installation instructions.

Hope this helps.

Thank you very much aankrah. Will try this thanks