Upgrade to ODK Central v1.2 error

1. What is the problem? Be very detailed.

Hello, I have just tried to upgrade my test server from v1.1 to v1.2, following the upgrade instructions. I do not see the new v1.2 functionalities and I get an error message "The page you requested could not be loaded. Please check that you are online and try again." on some pages (e.g. form versions, public access, settings, System - I suspect the ones that should have the new v1.2 functionalities), while I can still access other tabs / pages without any problem.

The first time I made the installation I forgot to check if the git status mentioned anything about the .env file, after having moved it and back, but when I checked it later, it looked all right. The installation seemed pretty smooth until I detected the problems with the web interface.

2. What app or server are you using and on what device and operating system? Include version numbers.

4f366fd674d83b7f2f156822e5a8d2ceca563b32 client (v1.2.0)
24d20de20fdf2e03b55e687542fbc0cae889a9ff server (v1.2.0)

3. What you have you tried to fix the problem?

I restarted the upgrade from start three times and checked every steps, but I did not detect anything weird.

4. What steps can we take to reproduce the problem?


5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

docker-compose ps outputs


Could you please try refreshing those pages?

1 Like

@LN ooh this indeed works now! I had relaunched my browser but had not thought of a problem with the cache :joy:


So glad to hear it was a simple fix! I was surprised by not seeing the new submissions table functionality on a server I hadn't logged onto in a while and that was also fixed by a refresh. I haven't needed to refresh on every server I've upgraded and have never seen the error you experienced. Unfortunately I think some of this caching behavior is browser-specific. Refreshing is always a good first step when experiencing something unexpected on the web! :sweat_smile:


Thanks a lot! I will certainly remember now :laughing:

1 Like

A post was split to a new topic: 500 when trying to log in after Central v1.2 upgrade

As of v1.3, Central will now alert you soon after a server upgrade, reminding you to refresh the page. If you navigate to a new page even before that alert is shown, you'll sometimes still see an error message. However, the error message now explicitly recommends refreshing the page. We're hoping that with these changes, this situation will be less confusing. Thank you for reporting this issue!

1 Like