Upgraded to Central V1.0 but no enketo buttons are avalible

1. What is the problem? Be very detailed.

I've successfully upgraded from central v0.8 to v1.0 but when I log into the frontend as an administrator there are no GUI's for Direct Web Browser Submissions under submissons and no tab for adding Public Access. It appears as everything is updated apart from the UI.

2. What app or server are you using and on what device and operating system? Include version numbers.

I'm using Central V1.0
4732f7112a286165241aaf7f971f2c2e38d6bb8a client (v1.0.0)
ad0719a2231fd85a70a64d82f2abc44c7a35de45 server (v1.0.0)

Running on DO with 2GB

3. What you have you tried to fix the problem?

I've tried rebuilding twice to see if this resolves the issue

4. What steps can we take to reproduce the problem?
Try upgrading from V0.8 to V1.0

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Here is a screen shot of the subbmissons page

This is the same for all projects and forms even those with submissions

Thanks for the detailed problem description. Did you go to <your uri>/version.txt to verify the versions? I'm wondering whether some of the frontend could be cached. What happens if you try this in a browser or device you haven't used before?

1 Like

OMG you're right can i delete my post from the history of the internet :man_facepalming:t2:


I'm very confident this will help someone in the future and they'll be grateful to you!!

The level of caching has surprised me in the past as well. For a future person running into this, most browsers have a hard refresh option that clears the cache. It's usually accessed with the keyboard shortcut CTRL/CMD+SHIFT+R. I now always do this if I don't see the web resource I expect.

I'm sure it will help someone and they’ll hopefully be a relieved as me that it's such a simple fix. I use chrome so Ctrl + F5 did the trick

1 Like