Upgrading to 1.3.4 causing 400 and 404 errors

Hello,

Sorry, I posted this before but can't find the post/not getting updated so
re-posting.

I upgraded ODK aggregate to 1.3.4 from 1.0.9. I can access all the data
that was previously uploaded, but any new forms trying to get uploaded are
met with 400 and 404 errors. As if the destination form has been
moved/deleted. What did I break while upgrading? We have about 1500 forms
not uploaded. Any solutions.

Thanks,

Mustafa

Mustafa,

That is skipping quite a few version and if we change the second number
there could be (and actually was) some special upgrade instructions
required. You moved past 1.1.x, 1.2.x, which means you should look at the
release notes and work backwards on what was need to be done to go from
1.0.x -> 1.1.x -> 1.2.x -> 1.3.x. NOTE: the instructions are platform
dependent.

Here is the historical release notes page:
http://code.google.com/p/opendatakit/wiki/AggregateReleaseNotes

Waylon

··· On Fri, Sep 6, 2013 at 12:33 AM, Mustafa Pirbhai wrote:

Hello,

Sorry, I posted this before but can't find the post/not getting updated so
re-posting.

I upgraded ODK aggregate to 1.3.4 from 1.0.9. I can access all the data
that was previously uploaded, but any new forms trying to get uploaded are
met with 400 and 404 errors. As if the destination form has been
moved/deleted. What did I break while upgrading? We have about 1500 forms
not uploaded. Any solutions.

Thanks,

Mustafa

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

The older now-deprecated versions of ODK Aggregate are available on
http://code.google.com/p/opendatakit/downloads/list -- just choose 'All
downloads' for the "Search" field and leave the "for" field blank, then
sort the resulting list by Filename.

The safest thing to do is to:
(1) re-install the older version of ODK Aggregate that you were originally
running
(2) disable all submissions for your ODK Aggregate instance (on the Form
Manager page),
(3) use ODK Briefcase to download a full copy of your data to your computer
(4) proceed with incrementally upgrading with each ODK Aggregate version
(5) then re-enable submissions once you are at 1.3.4

If you have not maintained your AppEngine server in a while, it is likely
that you will need to convert it from Master-Slave to High Replication. You
cannot do that until after you have upgraded to 1.3

Alternatively, it would be far easier to create a completely new
application ID, install the latest ODK Aggregate, then run ODK Briefcase to
push all the forms and submissions up to that new instance.

Mitch

··· On Sat, Sep 7, 2013 at 1:40 PM, W. Brunette wrote:

Mustafa,

That is skipping quite a few version and if we change the second number
there could be (and actually was) some special upgrade instructions
required. You moved past 1.1.x, 1.2.x, which means you should look at the
release notes and work backwards on what was need to be done to go from
1.0.x -> 1.1.x -> 1.2.x -> 1.3.x. NOTE: the instructions are platform
dependent.

Here is the historical release notes page:
http://code.google.com/p/opendatakit/wiki/AggregateReleaseNotes

Waylon

On Fri, Sep 6, 2013 at 12:33 AM, Mustafa Pirbhai info@tgharusha.comwrote:

Hello,

Sorry, I posted this before but can't find the post/not getting updated
so re-posting.

I upgraded ODK aggregate to 1.3.4 from 1.0.9. I can access all the data
that was previously uploaded, but any new forms trying to get uploaded are
met with 400 and 404 errors. As if the destination form has been
moved/deleted. What did I break while upgrading? We have about 1500 forms
not uploaded. Any solutions.

Thanks,

Mustafa

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"ODK Developers" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to opendatakit-developers+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Mitch Sundt
Software Engineer
University of Washington
mitchellsundt@gmail.com