XForm not validating due to an error with replacing a survey element

1. What is the problem? Be very detailed.
I am creating an XForm to collect some data. I am using pretty straight-forward concepts, and the most complex of them is pulldata(). However, I am meeting a problem validating it because I keep getting this error:

There has been a problem trying to replace ${name} with the XPath to the survey element named 'name'. There is no survey element with this name.

I have double-checked and I have no survey element called ${name} at all, except as the name of the column I need to grab from the dataset with pulldata().

2. What app or server are you using and on what device and operating system? Include version numbers.
I am using Google Sheets to create this, and validating it on Ona. I have also tried to validate it at xlsform/v1/.

3. What you have you tried to fix the problem?
I have checked the form over and over to see what the problem is, and it still doesn't work.

4. What steps can we take to reproduce the problem?
I have attached all 2 forms (XForm and dataset) plus the error message I keep getting.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.
boda pricing survey (2).xlsx (191.7 KB) drivers.csv (13.2 KB)

Due to being a new member, I could only include two links (each upload shows as a link). Here is the error message;

in your choices sheet the normal columns are "list_name", "name" and "label". you have "list_name", "value" and "label". You may need to change from "value" to "name" in column B


Thanks Noel. I will make the change. However, it won't solve the problem.

Thanks @noel_cartong. I have fixed the issue. I just realized that I am naming instances using actual field names from the survey, but had changed one of the field names without reflecting the change in the settings sheet.

Again, thank you very much. I really was stumped.