XLS form online problem with conversion of external choices

1. What is the problem? Be very detailed.
When converting xlsx to xls using odk-xlsform the itemsets.csv is empty even though there is external choices tab in the xlsx. Tried with two different forms that were working previously.

2. What app or server are you using and on what device and operating system? Include version numbers.
ODK Aggregate, ODK XLS form online

3. What you have you tried to fix the problem?
Check the column labels and data for fault, tried a different working form

4. What steps can we take to reproduce the problem?
Create a form with external choices and try to convert it. Open the itemsets.csv to view the data.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

We are glad that you are here. It would be easier for forum member to solve your problem if you could add your XLSForm here.
If you followed steps explained here http://xlsform.org/en/#external-selects then it should work

Thank you for the reply, Arif.

I have followed the instruction as far as I am aware. It was two of us checking the sheet.
I have now attached the XLSform. On my external choices tab, I have got a list of 'persons' the label column has got two dashes in front of the numbers. I have tried to remove these as I thought this might have caused the issue, but it did not help.

InOut.xlsx (276.0 KB)

You are right this site https://opendatakit.org/xlsform/ giving blank itemsets. You can get valid itemsts converting the file in offline tool https://github.com/opendatakit/xlsform-offline/releases/tag/v1.11.0

Hi Arif,
thank you for replying.
Is there a way of reporting this bug to ODK or would they pick it up from the forum?
I will download the offline tool now, I have actually copied the records manually in to the csv to make it work.

Looks like a bug in the Aug 12th release 1.6?

It should get picked up @yanokwa if it is a big in the above release.

The reported issue has been fixed in the newest releases of ODK XLSForm Online v1.6 and ODK XLSForm Offline v1.11.

1 Like

the same error occurred in v1.6.1 or what?