404 Error when deploying Aggregate on Tomcat cloud server

1. What is the problem? Be very detailed.
I want to deploy Aggregate on a cloud server so my team and I can collect data. I have not set up https or any other ways to access the server on the web, I'm simply trying to get it running. I have deployed the ODK-Aggregate-v2.0.3.war file to my tomcat servers webapps folder. I tried deploying a helloworld.zip and it ran and I could access it by clicking on the "open in browser" option on my cloud server provider. When I do the same after deploying the Aggregate war file, I get: "HTTP Status 404 – Not Found The origin server did not find a current representation for the target resource or is not willing to disclose that one exists." My Aggregate files are stored in the webapps/Root folder, the same as my helloworld.zip test file. For some reason the Aggregate web application is not launching and I get that 404 error.
2. What app or server are you using and on what device and operating system? Include version numbers.
I am using a Jelastic cloud server environment as my server provider. Tomcat 9.0.02. ODK-Aggregate-2.0.3 and PostgreSql 11.3. Java openJDK 12.0.1

3. What you have you tried to fix the problem?
I have tried to move the Aggregate files around to different folders and read carefully through the Tomcat, Jelastic and Aggregate docs. Nothing I've found addresses my problem exactly as the 404 error is very broad. I am very new to this but from what I can gather there is something wrong with my context or I need to do something in the Aggregate files so Tomcat can find them.
4. What steps can we take to reproduce the problem?
Deploy Aggregate on a Jelastic server running the same Tomcat version.
5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

26-Jun-2019 03:42:58.007 SEVERE [main] org.apache.catalina.core.StandardContext.startInternal One or more listeners failed to start. Full details will be found in the appropriate container log file
26-Jun-2019 03:42:58.015 SEVERE [main] org.apache.catalina.core.StandardContext.startInternal Context startup failed due to previous errors
Jun 26, 2019 3:42:58 AM org.apache.catalina.core.ApplicationContext log
INFO: Closing Spring root WebApplicationContext
26-Jun-2019 03:42:58.076 WARNING [main] org.apache.catalina.loader.WebappClassLoaderBase.clearReferencesJdbc The web application [ROOT] registered the JDBC driver [org.postgresql.Driver] but failed to unregister it when the web application was stopped. To prevent a memory leak, the JDBC Driver has been forcibly unregistered.
26-Jun-2019 03:42:58.083 INFO [main] org.apache.catalina.startup.HostConfig.deployWAR Deployment of web application archive [/opt/tomcat/webapps/ROOT.war] has finished in [3,707] ms
26-Jun-2019 03:42:58.089 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["http-nio-80"]
26-Jun-2019 03:42:58.096 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["http-nio-8080"]
26-Jun-2019 03:42:58.098 INFO [main] org.apache.coyote.AbstractProtocol.start Starting ProtocolHandler ["ajp-nio-8009"]
26-Jun-2019 03:42:58.101 INFO [main] org.apache.catalina.startup.Catalina.start Server startup in [3,887] milliseconds

-Thank You for taking time to look at this.

Welcome to the ODK forum, @elliott1177! We're glad you're here. When you get a chance, please introduce yourself on this forum thread. I'd also encourage you to add a real picture as your avatar because it helps build community!

I'm sorry you're having problems with your Aggregate deployment. The bad news is that you're really on uncharted territory since you're not using any of the stack part versions we actually test and support.

This docs page lists the parts and versions you should need to deploy:

  • Java 8
  • Tomcat 8.0 (8.5 is fine too)
  • PostgreSQL 9.4

This doesn't mean that with your stack versions it won't work. It means that we don't know or, at least, that we don't know the kind of problems you're going to run into.

In any case, the error you're experiencing looks a lot like another issue I've had when installing tomcat using apt in some particular Ubuntu versions. What I found is that some of the extra tomcat9-admin, tomcat9-user, etc. packages can get misconfigured and prevent the server's booting sequence. You can try to uninstall all tomcat packages but the tomcat9 package.

1 Like

Thank you so much for taking the time to respond. I will change my profile pic soon because I want to be apart of this community. I recreated my servers with OpenJDK 8.0.201, Tomcat 8.5.40 PostgreSQL 9.6.11. This is the closest I can get to recommended options. I am getting the same error. Is there any other advice you can give? I will start trying to make sense of the catalina.out logs. Thank you.

Hi, @elliott1177!

Did you have a chance to go over my comment about the tomcat packages? Does it apply to your scenario? It's the same idea, but with the tomcat8* packages.

1 Like

So I am not sure if apt was used when installing tomcat. I actually didn't install tomcat myself on this cloud provider, It is one of the options when I created the cloud environment in jelastic. So Tomcat was preloaded on this cloud server in the 8.5.40 version. I looked into the /opt folder and that seems to be where it's running from, that is where the /webapps folder is stored with aggregate on it. Was it the /opt folder you were talking about, if so I can't find how to delete tomcat9-admin and tomcat9-user files. If I can find those files I will try uninstalling them. What do you think? Let me know if you want to see any more screenshots.

This is a screenshot of my web.xml file, I have not changed it at all. I have a feeling something needs to be changed in this file.

To find out whether you have those packages you would have to open a terminal session into your server using ssh or something similar.

In any case, it's probably a misconfiguration of the server itself. You can prove that by completely removing the Aggregate files from tomcat and restarting it. It should still fail and you shouldn't be able to access the admin webapp, etc.

If you can confirm this, maybe the Jelastic support team can help you get your tomcat up and running and then, after verifying that Tomcat is working, you can attempt to install Aggregate.