413 Request Entity Too Large Error

Hi All
I am used to laying out survey questions using odk build, then export as XMl and insert the complex logic and questions grouping that I cant in the build GUI. Unfortunately, I have this tool i am building, quite huge, and when I try export as xml, i get this error msg "413 Request Entity Too Large". What the maximum number of questions one can lay out in build, I am not even halfway building the tool. Previously, build could accommodate larger sizes of questions than what I am working on. I can however export the tool into xls but i dont like the way the xml code is laid out after converting from xls to xml; the xml code is "dirty" in this kind of export hence prefer build.

This sounds like a bug in Build. @issa, can you help?

It's an nginx thing. I'll get to it soon.

Thanks @yanokwa @issa, apart from this issue the new build gui and additional features are great... Simple...

1 Like

Okay, @charles_gatama, I have raised the limit. Please give it a try again and let me know how it goes?

1 Like

@issa @yanokwa, great, I am now able to export the xml script file, it worked. Thanks. And thanks as well for the updated build gui, very simple, user friendly and with the additional features, all the feedback were incorporated to the new design. Just Awesome!

1 Like

@charles_gatama I'm glad it worked out, and thank you for the kind words! Community feedback is always welcome, as I am sure there is still a lot more we can do to make everything easier to use.

1 Like

Experiencing same problem in 2018?

I'm experiencing same problem, please solve the issue @issa

try again now?


I am also experiencing the same issue. the file is 7MB. Dear @issa please solve the issue.

hi semira:
7MB is definitely below the current limit, which is 15MB. if you're still seeing the problem it might be somewhere else before the request actually gets to Build. could you please describe exactly what steps you are taking and where and what the error message is? thanks!

It worked, thanks @issa

A post was split to a new topic: Entity too large in XLSForm