502 Bad Gateway nginx/1.14.0 (Ubuntu) while using ODK aggregate

1. What is the problem? Be very detailed.
I was using ODK aggregate server that we have, just like usual every single day. Here I export the data from the previous days work and then download it. While the exported data was generating into a csv file for me to download, the server and all ODK aggregate then stopped working and gave a page saying "502 Bad Gateway nginx/1.14.0 (Ubuntu)". Now I cannot access the server and it has been down all day.

2. What app or server are you using and on what device and operating system? Include version numbers.
ODK aggregate 1.14.0

3. What you have you tried to fix the problem?
I have checked if our digitalocean and freenom was expired or not paid, not the case. Everything is validated up for the next year. I have googled extensively and found various other problems that this is not surrounding but nothing exactly about this. I also restarted my laptop in case it was me that was the problem - still no dice.

4. What steps can we take to reproduce the problem?
I have absolutely no idea how to reproduce the problem aside from going into my ODK aggregate server.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Have you tried rebooting your server?

This might be a silly question, but how do you reboot the server?

Assuming you have command line access to the server, the following command should work: sudo reboot now

If you don't have command line access, then you probably didn't install the server software, so ask the person who installed the server to reboot the server.

It actually ended up being a memory issue! I resized the droplet and it is functioning now. Thank you for your suggestions!


I had this same "502 Bad Gateway nginx/1.14.0 (Ubuntu)" error on my ODK aggregate server early this morning and having found this thread; I rebooted my server as mentioned above using sudo reboot now

Woolaa, my site is up now.
Thought I should my testimony for another. :grinning:


Early today, just face the same issue, I rebooted my server with the command sudo reboot now. Big thanks to this community :grinning: :grinning:


@yanokwa thanks for the solution. sudo reboot now is perfect solution.