"Action failed or aborted by user"


i'm having some trouble installing ODK Aggregate with Google App Engine.
When I try to get the token from ODK Aggregate App Engine Updater it just says "status : Action failed or aborted by user" and nothing else.

The installing instructions seems to be for windows 7 but I'm using Windows 10 and the Google App Engine looks a bit different than the instructions' screenshots and I'm not sure if I am doing everything right.
If someone has had the same issue and solved it I would really appreciate any help.

Tried to install the Aggregate again and when the install is complete and it should open
the Updater it showed this.


  • Matti


Regarding the 1st issue: when you will get this screen, Make sure to provide your email address as a reference of your Gcloud account and then click on Delete Token and then Get Token. I know, it should not be like that; however, this is how it works sometimes. And them you will get a token from Google.

Regarding 2nd issue: Try to uninstall and and reinstall Java.


Strange. If the App Engine Updater ran at some point, then the problem probably isn't Java. But just to be sure, what happens when you run java --version in your command line?

Thanks for your answers. I solved the problem by installing Java 8 and running the Aggregate installer again.
Apparently it does not work with Java 11.

  • Matti

Glad you found a solution, @Matti. Just so we can try to track down the core problem, what version of Aggregate were you using? v1.6.1?

I'm using Aggregate v1.7.0