Alternative to Aggregate-Export or Briefcase-Pull for large dataset

What is the problem? Please be detailed. I have a large dataset. Attempting to Export to CSV in Aggregate or Pull in Briefcase fails. E.g. In Briefcase:
fetched instance 15047...
fetched instance 15048...
fetched instance 15049...
fetched instance 15050...
processing chunk 152...

Is there a work-around to get the data from Aggregate?

What ODK tool and version are you using? And on what device and operating system version? Aggregate 1 on G Apps, and Briefcase 1.8.0 on Win 7 Pro. Later versions of Briefcase do not seem to run properly on current computer (not fully tested, so cannot yet say for sure)

What steps can we take to reproduce the problem?

What you have you tried to fix the problem?

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

You need to use command line Interface for large dataset.
This link will helpful for you Working with command Line with the help of this you can export CSV directly and this also works on low internet connection.


You should use the latest version of Briefcase. If it doesn't run properly, then it'd be helpful to know what exactly you mean by that.

Also, what specific version of Aggregate are you using? (e.g., v1.7.1).

Hello Yaw,
Tried ODK Briefcase v1.14.0. GUI does not open. briefcase.log below:
2019-03-02 15:33:38,078 [main] ERROR o.o.briefcase.ui.MainBriefcaseWindow - Failed to launch GUI
java.lang.IllegalStateException: Duplicate key org.opendatakit.briefcase.model.FormStatus@31920ade
at$throwingMerger$0(Unknown Source)
at java.util.HashMap.merge(Unknown Source)
at$toMap$58(Unknown Source)
at$3ReducingSink.accept(Unknown Source)
at java.util.ArrayList$ArrayListSpliterator.forEachRemaining(Unknown Source)
at Source)
at Source)
at$ReduceOp.evaluateSequential(Unknown Source)
at Source)
at Source)
at org.opendatakit.briefcase.transfer.TransferForms.rebuildIndex(
at org.opendatakit.briefcase.transfer.TransferForms.(
at org.opendatakit.briefcase.transfer.TransferForms.from(
at org.opendatakit.briefcase.ui.push.PushPanel.from(
at org.opendatakit.briefcase.ui.MainBriefcaseWindow.(
at org.opendatakit.briefcase.ui.MainBriefcaseWindow.launchGUI(
at org.opendatakit.briefcase.Launcher.lambda$main$0(
at org.opendatakit.common.cli.Cli.lambda$run$5(
at java.lang.Iterable.forEach(Unknown Source)
at org.opendatakit.briefcase.Launcher.main(
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(

I'm using Aggregate v1.4.8 Production

Best regards

This problem sometimes happens if you have forms with the same name and form ID.

Here's what I'd recommend:

  1. Reset your Briefcase preferences: java -jar ODK-Briefcase-v1.14.0.jar --clear_prefs
  2. On launch, choose a new Briefcase storage folder
  3. Now try pulling.