Blank surveys won't download, please help :)

1. What is the problem? Be very detailed.
I can connect to my server on the app and see my blank surveys, but when I try to dl'd them, I get the error pictured below.

2. What app or server are you using and on what device and operating system? Include version numbers.
ODK Collect, the latest version

3. What you have you tried to fix the problem?
Deleted and reloaded the app, checked my surveys, logged out and back in

4. What steps can we take to reproduce the problem?
Login and try to download the survey username: sdelapena password: gostoves

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Hi @Samantha_dlp

It's because your server works only with http (not https) but if you list the available forms the result is:

<form url="">Peru NAMA Instrument Check</form>
<form url="">Perú_NAMA_SUMs_v3</form>
<form url="">PeruNAMA_KPT_Todoslosdías_v6</form>
<form url="">PeruNAMA_EncuestaParaTomadordeDecisiones_v5</form>
<form url="">PeruNAMA_EncuestaParaCocineroPrincipal_v9</form>

so every url contais https and ODK Collect is trying to use it. @ggalmazor do you know why and how to solve it in Aggregate?

Oh, I see that yes. Any help on how to change that would be greatly appreciated! I already dropped the 's' in when logging into the server. Thank you!!!

Is there a reason that you can't or don't want to use a secure connection for your server? If you don't, anyone could potentially get access to the data you are collecting, modify it, send it to an unexpected place, etc.

I highly recommend turning on SSL as described in the instructions at Then you would use a https URL and your form download should work.

Hi LN,

Thank you for your reply, I installed, however, on Google Cloud and I don't think I can go back and alter the settings? Do I have to start from scratch again? If I do, can I still use the same subdomain? What would be ideal is if I could just get those surveys to upload without that pesky 's'! I don't mind if the server is secure or not.

Hi @Samantha_dlp

The error on "connection refused" that you are getting i suspect is caused by some mis-configuration in the port used.

Your tomcat installation listens to port 80, it is important you configure this port during Aggregate configuration. If you decided to configure SSL, the default port that the installation will be listening to is 443.

At the moment i would advice you to start from scratch again and make sure to provide the same database credentials if you want to use the same database. Also, make sure you provide clearly the domain name during aggregate configuration ie:

Hi @dicksonsamwel

Thank you for the response. I built it on Google Cloud and just followed the directions given here:

Is changing the port something I can do when I build it again? Also, I don't think it goes over configuring SSL. Could the problem be with the subdomain I am using?

Thank you!

Hi all! I spoke to support at my host site (DreamHost) and they said they can't help, so I think it's a problem with my Google Cloud Platform setup. I started from scratch again like @dicksonsamwel suggested but i still get the same problem! :cry: Would anyone mind hopping on a Skype call to help? I's be happy to pay by the hour in PayPal or Venmo! Thank you!