Briefcase doesn't transfer GPS data

I'm using Collect v1.10.0 (and it it's great!)

I recently found the option for Geotrace so have tried to incorporate that using XLSForm.
I've written a form that allows me to either collect a GPS Point or Line (depending on what I'm recording). I created a group (called Geotag) so the 'options' are shown on a single screen. I've tested it in the field and collected point and line data, which are stored on the device. Happy day!

However, when I download the instances to my hard drive and pull the data via Briefcase (v1.7.0) the .csv file has empty columns for all GPS data. I can see the data in the corresponding xml instance, so I think the problem lies with Briefcase, but haven't found anything obvious to warn of this issue.

Am I doing something daft - does the group affect how the data is transferred, or does Briefcase not handle Geotrace? I deliberately upgraded to 1.7 today... I get the same behaviour with 1.4.6. The fact that points AND lines are ignored makes me wonder if it is the group at fault?

I saw a discussion about converting Geotrace to wkt format, but assumed that wouldn't affect whether the data could be imported into a .csv

Example 'xml' instances: (I have had to put swap < > for in to make the code show? Forgive my stupidity with this form!)
[Geotag][Point]57....... -2....... ..... 3.0[/Point][Line /][/Geotag]
[Geotag][Point /][Line]57.... -2.... .. 3.0;57.... -2.... ... 3.0;57.... -2.... ... 3.0;57.... -2.... ... 3.0;[/Line][/Geotag]

Neither of these records incorporate the listed data, although they have everything else...

Any help would be much appreciated - I'd love to avoid having to extract the data manually from the xml instances!

Many thanks.

Hi seewhy,

thank you for joining our community and sharing us your experience,

do you try to make a from with for example 4 GPS point (without grouping) and see if the data will displayed with briefcase.

try to add additional column to your form so you can test if the briefcase skip all data in the form or just Geo-data.

Best Regards

Hi Nader,
Thanks for your reply.

I have tested as you suggested:

I added geopoint (and geotrace, because I know how to party!) to the form without grouping. This now works as expected for both point and line data types.

I already had other data columns, which were being pulled correctly - that is why I raised the issue.

I have now managed to retrieve the data that I tried to collect by editing the xml of the form and the instances to remove the references to the [Geotag] group - it now imports correctly via Briefcase.

So maybe this is an issue that Briefcase can't handle geodata if it is in a group. I haven't found that documented, but that doesn't mean that it hasn't been!

Should I report as a bug, or a feature request? Or just put it down to a 'learning experience'...

Thanks for your help in resolving the issue - where is the best place to document this? There is a problem, a solution (sort of) and maybe some further work
Kind regards


Thanks for the good troubleshooting @seewhy and @Nader!

@seewhy this is a clear enough issue that it can be filed at if you are comfortable with that. If you can attach a small form that illustrates the problem, that will help make reproduction faster. Thanks!

1 Like