Briefcase - metainstanceid folders not being created

What is the problem? Please be detailed.
Instances not pulling into ODK Briefcase Storage > forms > form name > instances folder when pulling

What ODK tool and version are you using? And on what device and operating system version?

  • MacOS Mojave
  • ODK Briefcase - Tried 1.6.0 and 1.13.1

What steps can we take to reproduce the problem?

  • Create temporary folder with the following subfolders: forms instances and metadata
  • Extract instances from phones and place in the instances folder
  • Place corresponding ODK forms in the forms folder
  • Load ODK briefcase, and under Settings select the temporary folder as Storage Location (this will create a new folder in the temporty folder called ODK Briefcase Storage)
  • Navigate to Pull menu in ODK Briefcase, select Pull from > Collect Directory
  • Click Configure and select temporary folder
  • Select all forms and Pull
  • At this point, the forms folder held within the ODK Briefcase Storage folder will populate will the given forms. If the action executes correctly, the instances should populate under the ODK Briefcase Storage > forms > formname > instances folder. However, this is not happening

What you have you tried to fix the problem?

  • Tried 2 different versions of ODK Briefcase.
  • Tried to push to our server, hoping it would trigger something to happens.

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

Hi, @Joseph_E_Flack_IV!

I've failed to reproduce this issue with Briefcase v1.13.1.

In my case, I've copied the whole odk folder from my phone to my computer.

Could you attach to this thread Briefcase's log file?

Hi @ggalmazor! Thanks for your help.

I've contacted my colleague who is experiencing this issue. I will try to get the log file(s) for you.

1 Like

I've just received a/the log file. Hopefully this is what you are looking for!

briefcase 11.21.30 (22.7 KB)

1 Like

Thanks for the log file. Unfortunately, I don't see any clues as to why is not working for you...

At this point, there are two things we could try:

  1. Could you try to copy the whole odk folder from your device to yout computer, instead of copying the individual folders?

    For some reason, some Android phones won't copy everything. What I do is use a file explorer app to copy the odk folder at the root directory to a backup directory. Then, I copy the backup/odk folder into my computer. Only when I do that I get the whole odk collect storage folder.

  2. Could you send me a zip with your odk folder to Then I could use exactly what you have to try reproduce the error and debug it.

Hey @ggalmazor. Thanks again for all your help. Sucks that the log file wasn't revealing. I will convey this information to my colleague and we will get back to you.

1 Like