Briefcase split select-multiple unexpected behavior with grouped questions

This is in reference to the newly implement functionality in Briefcase v1.13.0 to split multiple selects into fields,

What is the problem? Please be detailed.
It seems that when the multiple select question is within a group and when the option to split multiples is activated, Briefcase exports the data values properly but fails to create the corresponding column heading. So I end up with a bunch of headless (or heading-less?) columns at the far right of my CSV file.

What ODK tool and version are you using? And on what device and operating system version?
ODK Collect v1.18.2
ODK Briefcase v1.13.0
ODK Aggregate on Google App Engine v1.6.1

What steps can we take to reproduce the problem?
Create a form with multiple selects within a group and export using Briefcase, enabling the split multiples option.

What you have you tried to fix the problem?
I moved the question that had the splitting issue out of the group and the split happened as it should be.
To correct the output data, I shifted the headings to the right in the proper places, and the data aligns properly with the correct column headings. This also mean that I have to manually create the headings for the missing columns.

Hi, @techGus!

Thanks for reporting this bug. I'll create an issue and work on a solution. This fix should go into 1.13.1 as soon as it's available.

Fix is done, pending review. I hope we can make a patch release really soon, although we were already planning a v1.14 release next week.

In case this takes longer than expected, you can use the JAR file I've attached to the PR, which includes the fix. It would be great to have your feedback on the fix :wink:

1 Like

Thanks @ggalmazor for the quick reply. I did a quick test run on the same dataset with the new version and it worked. The column headings were properly exported. :+1:

1 Like

Awesome, thanks, @techGus!


We've released Briefcase v1.13.1 which includes the fix we've talked about.

1 Like


I have the same problem with export data with selected option "Split select multiples" with my form. Export with Briefcase v1.13.1

Split select multiples - don't work with choice filters. But if create new version without choice filters and than push answers from version with filters, export works fine.

This is expected behavior. choice_filters are dynamic and so we don't have an easy way to figure which ones your submissions have in order to do the split. We documented this at

1 Like