Briefcase version 1.17.2 in CLI script

1. What is the problem? Be very detailed.

I am not able to export excrypted forms

2. What app or server are you using and on what device and operating system? Include version numbers.
Briefcase 1.17.2

3. What you have you tried to fix the problem?
Tried older version of Briefcase. Version 1.7 can export the forms.

4. What steps can we take to reproduce the problem?

Checked if data is downloading, it seem to work.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Attached is Briefcase.logbriefcase.txt (62.3 KB)

Hi, @paul_macharia!

It looks like the cache file in your storage directory and the metadata.json files of your forms are out of sync (not sure why, though).

The easiest way to fix this would involve removing some files from your storage directory:

  • backup your storage directory
  • remove the cache.ser file at the root of your storage directory
  • remove all the metadata.json files in your form directories.
  • Launch your Briefcase CLI command

Thanks @ggalmazor,

Will check it out and revert.

Paul Macharia

Hello @ggalmazor,

I hope you are keeping well, I am fine too.

On this error, I found the cause. An incomplete instance makes it the forms folder. It only contains the submission.xml file only. Complete instances contain 4 files namely *.jpg.enc, audit.csv.enc, submission.xml, submission.xml.enc.

ODK briefcase will not export data until this incomplete file is removed. I have over 38k of instances (fortunately I run the export daily and only look for the incomplete instance by date.

This incomplete instance also must be removed from the Aggregate server.

A few questions, how does an incomplete instance make it to the server? Could ODK Briefcase detect this and not pull the incomplete instance? Or maybe if it gets pulled skipped during the export process instead of preventing data from being exported?

I have attached a portion of the Briefcase log file.

PaulError log.txt (6.6 KB)