Browser does not load the Central management website

1. What is the problem? Be very detailed.
I have installed ODK Central on a local Ubuntu 20 Desktop machine. Running docker-compose ps I get the following

However, when going to browser and entering I get the following:

The central management website is not loaded

2. What app or server are you using and on what device and operating system? Include version numbers.
Ubuntu 20 Desktop (Running on VM Virtualbox hosted on Windows 10 machine)

3. What you have you tried to fix the problem?
I do not know where to begin to fix the issue. Tried both firefox and chrome browsers

4. What steps can we take to reproduce the problem?

Follow the instructions for installing ODK Central on a local Ubuntu machine. However, rather than setting up a domain name, I used the server IP address directly in the .env file (DOMAIN= Bundle everything into a server docker-compose build and start up central docker-compose up -d. Going to a browser and typing in the IP set in the .env file ( fails to show the management website instead giving the result seen in the attached screenshot

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

By default, Central uses Let's Encrypt to obtain an SSL security certificate, and for that to work you need to set up a domain name.

If you are installing on a local network, it can be a bit more challenging. There are several threads on the forum that discuss people's efforts doing so. For example:

Thanks for the response. I am not very conversant with certificates, and Central, bear with me here... so does this mean setting up a domain name automatically overcomes all the other certification issues, so all I am left with is to set up a domain name and Central takes care of the rest?

The defaults, including Let's Encrypt, assume a cloud environment - it's not as straight forward on a local network. You'll need a static IP address or you'll need to set up dynamic DNS, and a domain with the right records set up for your address. As it's a local network you may also need to configure your router to direct traffic correctly.

1 Like

It needs domain name. Will not work on bare IP address. Letsencrypt does not issue SSL certificate for bare IPs.

1 Like