Build error : ERROR [6/6] RUN apt-get update && apt-get install gettext-base

1. What is the issue? Please be detailed.
I have build ODK Central on my on-prem server with is a linux Centos 8. Earlier i was able to make the build and test but now i just changed the domain and when i am trying to make a build i'm getting the following error : "[6/6] RUN apt-get update && apt-get install gettext-base:
0.349 runc run failed: unable to start container process: error during container init: error mounting "/u000/docker/buildkit/executor/hosts.i2rzcu5g4405cpyy47pwikixf" to rootfs at "/etc/host
s": open /u000/docker/buildkit/executor/k90e6j6p4kn3dj6y3o1mwgcut/rootfs/etc/hosts: operation not permitted"

2. What steps can we take to reproduce this issue?
Not Sure if anyone else has faced this issue

3. What have you tried to fix the issue?
I tried few things but nothing seems to work. Does anyone has any idea on how to fix this?

4. Upload any forms or screenshots you can share publicly below.

I have the same error during docker build :

On debian12 bookworm (PI4).