returning npm ERR timeout

1. What is the issue? Please be detailed.
When installing odk central, i am facing an issue when I run docker compose build. It goes smoothly until it reach nginx service, there it goes until the line RUN files/prebuild/ and returns the following error.

=> ERROR [nginx intermediate 4/4] RUN files/prebuild/ 148.5s

[nginx intermediate 4/4] RUN files/prebuild/
147.0 npm ERR! code ERR_SOCKET_TIMEOUT
147.2 npm ERR! network Socket timeout
147.3 npm ERR! network This is a problem related to network connectivity.
147.3 npm ERR! network In most cases you are behind a proxy or have bad network settings.
147.3 npm ERR! network
147.3 npm ERR! network If you are behind a proxy, please make sure that the
147.3 npm ERR! network 'proxy' config is set properly. See: 'npm help config'
147.9 npm ERR! A complete log of this run can be found in:
147.9 npm ERR! /root/.npm/_logs/2023-09-17T18_38_33_131Z-debug-0.log

failed to solve: process "/bin/sh -c files/prebuild/" did not complete successfully: exit code: 1

2. What steps can we take to reproduce this issue?
Trying to install odk central at a vps.
ubuntu 20.04 LTS
10 GB Storage
512 RAM

3. What have you tried to fix the issue?

Tried running the docker compose build command multiple times, if maybe it was a network issue. Also tried build the nginx server alone; same result.

4. Upload any forms or screenshots you can share publicly below.

Hi @Yoseph_Tenaw
When you get a chance, please introduce yourself here. I'd also encourage you to add a real picture as your avatar because it helps build community!

Are you behind a proxy as the logs say?
Have you tried anything from
It seems like there might be more about the issue in:

147.9 npm ERR! A complete log of this run can be found in:
147.9 npm ERR! /root/.npm/_logs/2023-09-17T18_38_33_131Z-debug-0.log

Could you attach those logs too?