Cannot access ODK Central - Your connection is not private error

1. What is the problem? Be very detailed.

I cannot open ODK central server recently and it is shown " Your connection is not private". We didn't do anything to effect on server, only ODK collect App have been using.

2. What app or server are you using and on what device and operating system? Include version numbers.
ODK Central Server host on Digital ocean
Browse on Window 10

3. What you have you tried to fix the problem?
I've checked the date and time setting on Chrome and also tried to open it on different browsers on different PC.

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Thank you in advance.

Welcome to the forum @Thin_Wut_yee and thanks for adding your profile picture; it helps to build community! We're glad you're here. When you get a chance, please introduce yourself on this forum thread.

1 Like