Cannot get blank forms on a new phones ODK Collect nor access the server from ODK Briefcase

Hi my name is Tyler and I use ODK to collect snake ecology data from the field in Thailand.

What is the problem? Please be detailed.

I lost my previous phone which I had used ODK Collect on and recently purchased a Motorola 5g Plus. I have installed ODK Collect (v1.10.2) and have filled out the URL, username, and password fields under 'general settings' just as I had done with my previous device. When attempting to "Get Blank Forms" I get an error message that reads:

"Form listing failed. ContentType:text/html; charset=UTM-8 returned from: URLfromList is not text/xml. This is often caused a network proxy. Do you need to login to your network?."

I have tried accessing blank forms on this new phone using both the wifi at the research station where I live, and the network data on my phones AIS 4G data plan without luck. I am not using any proxies or VPN changing programs.

Additionally, when I try to Pull forms from Aggregate using ODK Briefcase which I have successfully installed on my Acer computer, I get an error:

"Unable to fetch formList: A non-XML document was returned while accessing: URLfromList A network login screen may be interfering with the transmission to the server. If you are behind a proxy, try setting up your proxy details through 'Settings' tab."

These forms have not been adjusted in Aggregate since their creation and worked fine on my previous cell phone. I can sign into Aggregate and access my XML form and past data for export from both my PC and from my Motorola cell.

What ODK tool and version are you using? And on what device and operating system version?
Motorola g5 Plus with ODK Collect v1.10.2 and Acer Aspire E 15 (AMD A10) with Windows 10

What steps can we take to reproduce the problem?
Steps in problem description ^

What you have you tried to fix the problem?
Using multiple internet sources without proxy or VPN. And have updated billing information on google cloud account to resolve surpassing data quota.

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.
My aggregate account has 3 admins and is used by Collect and has been used on three other phones.

Hi Tyler! Thanks for your very detailed support request. It makes it much easier to troubleshoot.

Based on real life experience using Wi-Fi and AIS in Thailand, I can tell you that there is a fair bit of proxying and filtering and blocking by the providers and the government. Couple of things to try...

  1. Please confirm that your computer with Briefcase (what version?) used to work. If it worked before, then the problem likely has to do with your server or connection.
  2. Can you sure the URL to your server is correct? For example, whether it's http or https makes a difference.
  3. Is there a phone you used to use or a friend's computer that Collect or Briefcase works on? That is, is this a problem only on your phone and your computer?

P.S. Please introduce yourself here and tell us more about your snake ecology work. Sounds so cool! :snake: