Cannot install forms to ODK Central

I have just installed ODK Central on a AWS server and t appears to work. I have created a user and made it administrator. All this following instructions here and linked pages. Using Ubuntu 20.04.3, Docker info as below.

Client: Docker Engine - Community
Version: 20.10.12
API version: 1.41
Go version: go1.16.12
Git commit: e91ed57
Built: Mon Dec 13 11:45:33 2021
OS/Arch: linux/amd64
Context: default
Experimental: true

Server: Docker Engine - Community
Version: 20.10.12
API version: 1.41 (minimum version 1.12)
Go version: go1.16.12
Git commit: 459d0df
Built: Mon Dec 13 11:43:42 2021
OS/Arch: linux/amd64
Experimental: false
Version: 1.4.12
GitCommit: 7b11cfaabd73bb80907dd23182b9347b4245eb5d
Version: 1.0.2
GitCommit: v1.0.2-0-g52b36a2
Version: 0.19.0
GitCommit: de40ad0

Central rports itslef as:

24ee74e5f974a518aa1cc8b06e7addb3be6b4690 (v1.3.3-2-g24ee74e)
5cc6fd79d112ce36d6298c61bb8817689c4c323b client (v1.3.2)
1d1a3a59969e61383da74119e405e67778b7a170 server (v1.3.3)

However I cannot upload forms. I have tried one I have created myself at (xlsx xmal formats) and sample xlsx i found on the web. I alwasy get "Something went wrong error 500"

I have tried uploading samples an image of the error and of forms but I always get "new users can only upload 2 links)

Here is a sample form and an image of the error (maybe)
Pond-Report-export.xlsx (16.9 KB)

Hi @mnewmana! I was able to upload the form to another server running on AWS, so I don't think the form is the issue. Do you also see the error when you upload an XML file, or only when you upload an XLSForm?

It'd be helpful to see your server's log. To find that, log into your server, navigate to the project folder (cd central), then type:

docker-compose logs nginx

You can then copy the output here.

Many thanks for your reply.

OK there is clearly a permissions issue as I get “cannot create temporary directory” when I attempt to get the logs with the docker command above

Turns out the issue was disk space. It turns out the default disk size for a t2.micro AWS instance is too small which I don't think is mentioned in the guidance on setting up in AWS. In anything other than a PoC installation I am sure you'd use something beefier anyway, but I was just blindly following the guide to get a small install to see if ODK was for us..