Cannot zoom in to full zoom on GeoODK Collect using offline map

I am running version 2.0.4 of GeoODK Collect on my phone (Google Pixel). I went through the process of creating ".mbtiles" files using tile mill and have transferred them to my phone. In tilemill I have set the maximum zoom to 21 or 22. However, when I load the .mbtiles on my phone and try to access them with GeoODK I cannot zoom in all the way. My zoom level stops at what I believe is 18 or 19. I am using satellite imagery, so this is insufficient for my mapping needs.

I am hoping someone has encountered this issue before and can provide some guidance how to set up GeoODK such that I can zoom in all the way using my offline maps.

I took a .mbtiles file off another android tablet that a colleague is using. On his tablet it allows for zoom up to level 21 (which is the max), but on my phone I cannot reach the same level of zoom. This makes me believe it is not an error with the .mbtiles files but instead some other setting.

I have attached a photo showing the maximum zoom level I can achieve on my phone. Please let me know if you have any idea how to resolve this issue. Thanks!

Hi @Drew_Capone

This forum for the Open Data Kit project tools. GeoODK is s derivative of ODK Collect, you can reach out to the GeoODK community for better assistance

Thanks for the suggestion! I'm new to the ODK/GeoODK community. I'll ask over there.