Can't capture image in ODK Collect

1. What is the problem? Be very detailed.

Can't capture the image using camera inside the forms. After clicking the button on the camera, it directs to choosing photo in gallery but there's no image saved.

2. What app or server are you using and on what device and operating system? Include version numbers.

I am using Samsung A5 2017 smartphone

3. What you have you tried to fix the problem?

I've searched for the same problem in the forum but there's no possible solution founded.

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.


You should get two options instead of one, to capture and to browse picture from device. Have you tried in another version of android? If it works on another version of android, you may report this issue.

Welcome to the ODK forum, @angeliquedc! We're glad you're here. When you get a chance, please Introduce yourself here!. I'd also encourage you to add a real picture as your avatar because it helps build community!


It has two options, capturing image and browsing image from device. I haven't tried it in another version yet. I'll let you know if it worked.



If you tap on capture image, the camera will turn on to capture image instead of browsing from device.


What camera app do you use? It might be a bug there.

If I tapped the capture image, it will be redirected automatically to selecting pictures.

i'm using the device camera.

So both Take Picture and Choose Image have the same behavior (start the gallery)?

1 Like


Try collect on another device. Sometimes you may experience issues with camera even with the device. Please note that, Android phone manufacturers customize the OS to offer additional features which cause issues.

It is working properly on other device.


What device does it work on and what device doesn't it work on?

1 Like