Can't Get Central Login Screen - Ubuntu on Hyper-V

1. What is the problem? Be very detailed.

Can't get any login screen on fresh install, either via LAN or WAN, direct to IP or Domain

2. What app or server are you using and on what device and operating system? Include version numbers.

Ubuntu 20.04, Docker Engine (Assuming latest as of today) and Docker Compose 1.29.2. Running via Hyper-V server behind OPNSense firewall. Firewall has ports 80 and 443 forwarded to the VM's LAN IP. DNS records both internally and externally (I run split-DNS) point to the right IP addresses.

3. What you have you tried to fix the problem?

Checked all Docker containers are running as per install instructions.

Numerous versions of Docker Compose, opening all ports on OPNSense firewall, 'ufw disable' in Ubuntu.

Checked pings (can ping the server from the LAN but not the WAN) checked DNS records resolve to correct IP addresses.

Tried different web browsers and clearing client machine DNS cache. Also tried accessing from external machine over WAN and tried 1:1 NAT i.e. all ports open on VM's IP.

4. What steps can we take to reproduce the problem?

Install on a virtual machine with static IP on LAN, forward ports 80 and 443 to it, create both external and internal DNS A records pointing to relevent addresses.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Noticed that browsers seem to redirect to HTTPS:// before failing to load the page, suggesting that the server is reached and the issue lies within the install.

My DNS records and .env set the address as, so a subdomain. Not sure if this matters.


@mrrodge As you can't get any login screen, could you please attach a screenshot of what you get upon opening the server URL?

Sorry for the delay in replying - I was testing my network first to make sure. Screenshot below (Firefox):

Resolved! Think it was some browser sillyness. Apologies for any inconvenience!