Cascade filtered choice and xlsform on line

1. What is the problem? Be very detailed.

I used xlsform with cascade choice usind the choice_filter colum

With OdK XLS off Line (v1.10) every thing is fine (and the form work fine)
but with OdK XLS On line, Compil fail woth this message :
Error: ODK Validate Errors:

XForm is invalid. See above for the errors.
: node for itemset doesn't exist! [instance(doc_presente)/root/item/label]
doc_presente is the name of my list

I have this colum on my choice tab :
list_name | name | label | ciblage | theme | theme2 | theme3 | pays | RSE

2. What app or server are you using and on what device and operating system? Include version numbers.

ODK 1.26 ODKOffLine1.10 and ODK XLS on line v2.0

3. What you have you tried to fix the problem?
If I delete all constraints in choice_filter colum it works

Unfortunately this is going to be really hard to troubleshoot without the XLSForm. Is it one that you can share publicly? If you can't share the whole form, can you try removing everything except for the question that you are applying the choice_filter to and any groups or repeats it is in and see if you still get the same problem? If so, that would be helpful to share.

I try to simplfy my form. but the simplified form works...
I try to understand what are the difference between both form which can explain the problem
tst.xlsx (125,1 Ko)

1 Like

Great strategy! Please keep us updated.

I even test changing Row 8 to calculate and note and all of them worked on your XLS form.

This is very old, but it wasn't fully resolved so I am sharing my solution for anybody else that finds this problem.

In my form this was nothing to do with the cascade but instead with the language support. In the choices sheet I have a language support column (label::french(FR)) and I was nesting a variable trap (column list_name) within village (column village). I got the same error that Fabienne described because I had partially completed the column label::french(FR) for the variable trap. By completely filling the language support column with all trap labels this resolved the error.