Central files not found after changing storage-driver settings

1. What is the problem? Be very detailed.
I recently resized my digital ocean droplet and because this was done when the disk was full it lead to some problems but after deleting some files all worked out well but running df -h suggested that there was some merged overlayed images. So to resolve this I followed a solution where I was told to include this {
"storage-driver": "overlay"

In the /etc/docker/daemon.json and then run sudo systemctl restart docker. When indeed the overlayed merged images were deleted but I could not access my odk central anymore so I run docker-compose up -d this I was hoping it would just restart the system but it instead built a new odk central installation now all my forms are gone.

2. What app or server are you using and on what device and operating system? Include version numbers.

3. What you have you tried to fix the problem?

4. What steps can we take to reproduce the problem?

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Please see this troubleshooting section and this forum post. You will want to review the install docs and related warnings about Docker usage as well.

I also recommend following up with the person who gave you this suggestion and they may be able to provide more assistance. This is not in the management steps that we recommend for Central.

1 Like

Thanks for the feedback. I have gone through all the volumes listed under "docker volume ls" but they all return No such file or directory when I run file /var/lib/docker/volumes/{letters and numbers}/_data/pg_hba.conf on them. But the strange thing is that even the volume that is attached to the current odk central db returns no such file or directory. When I run "df -h" I get back the results in the screenshot attached that shows there is data in the volumes in the overlay directory given their file size. Wondering if I should use one of those volumes to restore the data. Or if you have any other suggestions

Your original change forced usage of the older and less stable overlay storage driver. Typical Central installations use overlay2 and we don't have experience making this kind of change. Perhaps you could consider wiping this install and then restoring from backup (if you have a backup)?

Alternately you can ls in each of your overlay subdirectories and see if you can find something that looks like a postgres directory. I also don't know whether reverting back to overlay changes the structure of the volumes directories. You could manually inspect those directories to look for something that looks like a postgres directory.


Thank you so much ended up restoring the droplet from a snapshot I created.