Data in limbo - bad URL/missing submission URL

1. What is the issue? Please be detailed.
My data is stuck in limbo and I cannot access it! The issue I have is operator error by a beginner with ODK. The excel template I used had "submission url" instead of "submission_url" on the settings page. I neglected to test sending before entering data, and so it is only now that I have finalized and tried to send the saved forms that I am finding this issue. I can't access the saved forms anymore, they are stuck in a limbo of "sending failed" because of "missing submission URL". At this point I can no longer view the data within the forms on the ODK app on my tablet. It just says "sending failed" under Send Finalized Form, and I can't open the forms.

2. What steps can we take to reproduce this issue?
Reproducing - make a form, on setting change the submission_url to submission url... Then try to send the finalized form to a linked google spreadsheet. The error message should come up on the ODK app.

3. What have you tried to fix the issue?
Nothing - no idea. Just tried clicking around on the ODK app to no avail.

Thanks for any advice!

4. Upload any test forms or screenshots below.

Always do a few test entries before collecting actual data, and make sure you do not have a permission issue.
In my opinion, you can not make the existing form on tablet to work and send data to Google spreadsheet, but you can retrieve the data from your tablet provided that you have not deleted the finalized forms.
Connect tablet to a computer, navigate to android->org.odk.collect->projects->project->instances folder. You will see the data in xml form. Parse the xml data with python, php, R etc.,
If you want to send the data to Google spreadsheet, make another working form (without changes to the form fields). Copy the instances from old form and paste them in the instance folder of new form. Open odk collect. You will see the old forms ready to submit to Google sheet.