Data not publishing on to Google Spreadsheets

Hello Again,

Have another question. This has happened to me on multiple occasions.

Once a form has been completed and sent, the data gets stored on the aggregate - I can see the data when exported onto CSV. But somehow on occasions, it refuses to get published onto google spreadsheets. I make sure the choice is New and Existing, I access it via simple gmail domain ID, but somehow on certain occasions it just doesnt publish onto google spreadsheets.

Any one with any suggestions on what may be going wrong here?

SamaitShalaDemoParticipantFeedbackSession (10).xml (11.7 KB)

SamaitShalaDemoParticipantFeedbackSession.xlsx (15.5 KB)

Any thoughts, anyone ?

I've had this issue happen a few times. Certain forms, especially those with no/little media would be published + steam new data to Google Sheets. Larger/bulkier forms would not. I had a blank spreadsheet created in my Google Drive, so I know the connection was not an issue, but the data would not stream to the sheet. Note: The Aggregate server was version <2.0, and was hosted on GCP.

I've since moved hosting Aggregate to MS Azure. Will update asap on if the same issue persists.

Sorry, I know its not useful to @Prasanna_Sundaram, but I thought I'd also update a similar issue on the thread.

1 Like

Hey @Vanubhav , thank you, this rather helps me get closer to something at least. In my case the form I am using very very simple. It does have 3 media files though. You think that maybe causing the issue?

I dont know if the media files are causing the issue. I'm not sure why they would, but it could be linked to the size of the form+media. I couldnt update the Aggregate version on GCP as it was linked to a dashboard which was configured specifically for the data streaming from that version of Aggregate.

On the Azure deployment, we're running the latest (>2.0) Aggregate version. I'm hoping that this issue was limited to the ODK-GCP split, and wont be an issue on other platforms. That being said, I'm not sure if the ODK support to publish to Google Sheets will continue.

1 Like

Why do you say that Vanubhav? Are they closing away with Google Sheets? What is the alternate plan then?

Just bringing this back one more time. I can see the data when I export the data on to a CSV but unable to publish to Google Sheets. Anyone, any clue?

Seems like its happening to some particular forms only. there is a bug in something I have created which is not allowing it to publish it google sheets, while it available on the server.

Figured it out ... finally .... For anyone following this thread -

All "Names" need to be unique in their naming, and it is usually expected that it gets caught in the XLS conversation, seems like sometimes it can slip off. So while my form was uploaded, downloaded, filled, and data was sent to server, the publishing wasn't happening on Google Sheets.

All I had to do was rename notes_2 ( that was mentioned in 3 different places) to notes_1, notes_2, and notes_3 - it worked perfectly well.

So it may not be a server question at all - just go back and check for every little detail in your forms, the error must be lying there.

The unique name restriction should be caught by pyxform. How are you converting from XLS to XML? If you can, include version numbers of the tool you are using.

1 Like

Hi @yanokwa ,

I am using to convert the XML into XLS.

You should be able to see the excel versions in the links I attached earlier. You will find "Notes" for a couple of similar questions. You will notice I called them all as "Notes_2".

I am sorry but could you help me know how do I check the version numbers and get back to you.

1 Like

Well, this doesnt seem to be the issue for me. The forms which were previously publishing to Spreadsheets had the same variables/headers (all unique). Also, wouldnt the xlsx -> xml converter catch same variables/headers?

It didnt man. I have the XML XLS versions attached above. Try running it at your end and see what happens? In my case, it was this, I am guessing you might have had a mismatch in characters or space or something. Then again, just guessing. Mine worked thankfully and for now I am celebrating, until the next issue arrives :slight_smile: