Displaying data label from multi_choice question

What is the problem? Please be detailed.
Hi Team,

Can anyone assist me me here, I want to display data label from a previous multichoice question however if I use the usual ${multi_choiceqtn} i end up with the internal value associated with the question and not the label.
Attached is an example of excel sheet to elaborate.
biz.xlsx (14.3 KB)

What ODK tool and version are you using? And on what device and operating system version?

What steps can we take to reproduce the problem?

What you have you tried to fix the problem?

Anything else we should know or have? If you have a test form or screenshots or logs, attach here.

Hi @rigs

I know it's a little bit laborious solution but as I know it's the only one:
choice-name.xlsx (9.2 KB)

concat + choice-name + selected-at

1 Like


When I try to validate the form you've just shared I get the below error message, seems it may not work well.

  • FormLogicError: Could not evaluate: jr:choice-name(selected-at( /model/instance[1]/choice-name/school , 0), ' /choice-name/school '), message: Function "{http://openrosa.org/javarosa}choice-name" does not exist.

What tool do you use? I just used http://opendatakit.org/xlsform/ for converting and copied an output xml file to ODK Collect and everything was ok.

1 Like

Not sure if the error could be from my machine coz we are using same tool/platform for validation yet I get the error as below

Yes I noticed the same error in Enketo don't know why but everything works well on ODK Collect.

1 Like