Docker-compose build error : Service 'secrets' failed to build :unauthorized , authentication required

1. What is the problem? Be very detailed.
I would like to install odk centrall using centOS v.8. I install docker-ce, and docker-compose and follow steps in When I run docker-compose build in the central directory I am having that error : Docker-compose build error : " Service 'secrets' failed to build :unauthorized , authentication required " and I have tried to fix this error but in vain. Could you please help me out with this?

2. What app or server are you using and on what device and operating system? Include version numbers.
Server using VM-Centos V8

3. What you have you tried to fix the problem?
update .env

4. What steps can we take to reproduce the problem?

install odk central on clean centos V.8

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below. central]#
docker-compose build
postgres uses an image, skipping
mail uses an image, skipping
pyxform uses an image, skipping
enketo_redis_main uses an image, skipping
enketo_redis_cache uses an image, skipping
Building secrets
Step 1/2 : FROM node:12.6.0
12.6.0: Pulling from library/node
a4d8138d0f6b: Pull complete
dbdc36973392: Pull complete
f59d6d019dd5: Pull complete
aaef3e026258: Downloading [========================================> ] 40.25MB/50.07MB
6e454d3b6c28: Downloading [========> ] 35.85MB/215.1MB
c717a7c205aa: Downloading
e8566b4564fe: Waiting
04239395be03: Waiting![docker-compose build error|690x265]
27ace7d95321: Waiting
ERROR: Service 'secrets' failed to build : unauthorized: authentication required


This doesn't seem specifically related to Central. Did you look at some of the ideas at

checked the ideas in then I set the correct time using timedatectl set time <hh:mm:ss>. then do a reboot then run docker-compose build again and issue fixed.


1 Like