"Document has no root element" error message


Hi. Currently, I am using ODK Collect v1.29.3 and the KoboToolBox server. However, recently I had a problem concerning the forms update. There are some times that I update the forms on ODK Collect and when I try to open a form, the ODK Collect shows this error message: "Document has no root element!"

This error also occured when I used Kobo Collect v1.28.0

Steps to Reproduce

  1. On the Form Management page, set Blank form update mode as Exactly match server
  2. Try updating a form several times until you see the error message.

We saw this same error message in all of our current forms and in all of our devices. All of these devices are Android 10.0.0 smartphones which are either Sansumg or LG brands


Thanks for posting about this! Can you please share one of the forms you are experiencing this with? If it's not sensitive, attaching it to a response would be ideal. If it is sensitive you could send a direct message to me, to another of the core developers or an email to the support address listed. We would use the form for troubleshooting and then delete it.

1 Like

Hi, @LN
Thanks for helping us! @ricardonfc will soon be sending you a direct message with a sample form. But it is strange how forms that have been in use since the beginning of last year and have always worked properly are presenting the same problem.

We noticed the first occurrence of the problem on 12/01/2021, from when it became recurrent and spread to other forms. We are asking our enumerators to continue updating the forms until the "form updated successfully" message appears. This is solving the problem for now.

I can now reproduce so no need to send a form, thanks. When you say 12/01/2021, you mean January 12th, not December 1st, right?

Exactly, January 12th.

1 Like

Thank you both @ricardonfc and @nnsdtr_github for reporting this issue. It should now be fixed by v1.29.4 which is currently rolling out. Please try it and let us know your experience.

1 Like

It is I who should be thanking you! :slightly_smiling_face:

We will observe ODK Collect's behavior throughout the week and then give you a feedback.


Thank you very much LN! We will pay attention on both ODK Collect and KoboToolBox behaviour.

1 Like

Hi, @LN

ODK Collect is apparently working well. Our enumerators haven't mentioned any problems during this week. In any case, we'll keep watching its behavior.

As always, thanks a lot for the support!

1 Like

Hello there!
I face exactly the same problem.
I tried to disinstall my KoBoCollect version v1.29.3 and reinstall the only available version v1.29.3 -1-g03269b9e9 with updates on 16 January 2021.

However, I still face the same problem.. and I cannot access a later version because, apparently, this is the only version available on Google play..
Any thoughts?

ps. I shooted a message a couple of days ago in KoBoCommunity.

Please use ODK Collect if you would like to get the latest bug fixes.

1 Like

@Lavinia_Plataroti I think that, usually, KoboCollect takes a little bit longer to update than ODK Collect, so, maybe its better for you to use ODK Collect

1 Like