Enketo not working on my ODK Central Server

1. What is the issue? Please be detailed. Enketo has not been working at all for a few weeks now. Initially, the previews for forms was taking about 24 hours to load, but now, Enketo is not working at all. The public access links i've created are not working, and the page never loads. And my form previews for new forms created are not available.

2. What steps can we take to reproduce this issue? I am not certain - if i upload a new form, the preview button remains greyed out for days now. Here is one of the public access links that should be working: https://pidodkserver.co.za/-/single/osGy3xNv4FPyaClHv77osmyb0KYFGM5?st=KRoZ5SEUNxwVb!ZHbDBLnZ5Weqe4VdRdI67XYdIZeche3JQzJq3fWauBVgL6fgcX

3. What have you tried to fix the issue? I have tried to free up space on my ODK Central server.

4. Upload any forms or screenshots you can share publicly below.

You are running a very old version of Central. Please upgrade to the latest version of Central (currently v2023.1) to fix this preview problem and get the latest features and security updates. https://docs.getodk.org/central-upgrade has guidance on upgrades.

If you are not able to upgrade immediately, run docker-compose restart service to prompt Central to try a rebuild of those previews. It should only take a few minutes after the restart to rebuild.

1 Like