Error building enketo when upgrading to ODK Central 1.0


I tried to update to the latest version of ODK central (1.0) following the tutorial ( My current version is 0.9.

running docker-compose build I get the warnings/error

Running "shell:babel" (shell) task>> KilledWarning: Done, with errors: command "npx babel public/js/build/enketo-webform-bundle.js --out-file public/js/build/enketo-webform-bundle.js&&npx babel public/js/build/enketo-webform-edit-bundle.js --out-file public/js/build/enketo-webform-edit-bundle.js&&npx babel public/js/build/enketo-webform-view-bundle.js --out-file public/js/build/enketo-webform-view-bundle.js&&npx babel public/js/build/enketo-offline-fallback-bundle.js --out-file public/js/build/enketo-offline-fallback-bundle.js" (target "babel") exited with code 137. Use --force to continue.
Aborted due to warnings.

ERROR: Service 'enketo' failed to build: The command '/bin/sh -c grunt' returned a non-zero code: 6-

Do I need to run the command with --force? Is this a known behavior?
I also get (during the build process) some npm messages that some grunt modules are not installed (e.g., grunt-concurrent, grunt-contrib-watch). Might it be the cause of the problem?

Thank you for your support!

What specs are the machine/container you're running on? I ran into a problem with 1.0 on a 1GB Digital Ocean droplet with Babel but was able to upgrade once I resized to 2GB.

1 Like

resizing the droplet (2GB) worked.

1 Like

Ah good. There is a fix on the way for that. You should be able to resize down to 1GB again now you've upgraded.