Error Code: 1 (SQLITE_ERROR)

1. What is the problem? Be very detailed.
We are currently running a survey with ODK. Yesterday we could not upload the collected data from one of the tablets. The Error Code: 1 (SQLITE_ERROR) appeared with additional text when opening ODK. See the screenshot below. We cannot click anything and might only be able to reinstall ODK which means we would lose all the data collected on that day. Is there any way to save the data?

2. What app or server are you using and on what device and operating system? Include version numbers.
ODK collect; Samsung Galaxy Tab A.
Android version 5.0.2

3. What you have you tried to fix the problem?
We could not do anything as the message remained and we could not upload the data.

4. What steps can we take to reproduce the problem?
Not sure, we do not know how this error occured; we have been running the survey successfully for 3 weeks.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.
We had uploaded a new questionnaire form on that day to all the 60 tablets we are using - the problem did not occur on any of the other tablets.

Hi @Friederike
welcome to the forum! Please introduce yourself here!

could you share you instances.db file with me? You can send it via email if you don't want other users to see it (gorczykowski@soldevelo.com). The file is on your sdcard in /odk/metadata/ dir please copy it and send me I'll try to help.

1 Like

Sure, I just asked my team to send it to me. I just learnt from one of our team member that we use on this tablet and only this Android 7.1.1. Probably that is the reason.
Thanks!

I'll add that @Grzesiek2010 is part of the Collect development team. We have reports of this type of error from users every once in a while (e.g. ODK Collect App Error on Mobile Phone) but we can't reproduce it as part of our testing which makes it hard to address. Seeing the state of your device's database file would really help us track this down.

Is it possible that someone installed another app based on an older version of Collect at some point? That could be Kobo Collect, for example.

I just sent the db file to @Grzesiek2010 per email. Shall I send it to you too? No, to the best of my knowledge these tablets had not been used for any kind of ODK app before. And for our project we only worked with collect.
Thanks!

I just learnt from our team that on this tablet actually there was Kobo installed; they deinstalled it but it did not help to solve the problem.

1 Like

Thanks!
I've just sent you your database with a fix (I hope), please paste it to your metadata dir and open the app.
Using ODK Collect and any of its forks like Kobo at the same time might cause some strange problem. Not long ago I added some improvements and we have way less such problems but unfortunately it's not possible to handle every case.

1 Like

I just heard back from our team. It worked out! Thank you so much for the support!!!

I am currently having exactly the same problem. I have uninstalled KoboCollect as suggested in one of the replies but the error still persists. Please what do you need me to provide to have this error fixed. thanks

The same file I asked for above.