Error: Generic Expection: Error: (500)

  1. What is the problem? Be very detailed.

Get an error when I want to upload the results of a test survey. Before publishing the final draft I wanted to test it, but can't upload the results.

What app or server are you using and on what device and operating system? Include version numbers.

ODK Collect v2022.1.0, both on a Xiaomi Android phone and on a GalaxyTabA7Lite

What you have you tried to fix the problem?

I created uploaded over and over the XLS survey and test it many times
I updated the ODK collect version

What steps can we take to reproduce the problem?

Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

Welcome to the forum @pablo.perez and thanks for adding your profile picture. It helps build community! When you get a chance, please introduce yourself on this forum thread.

For your server, are you using Aggregate? Central? Or something else?

The URL suggests it's Aggregate. And the 500 error suggests the Google Cloud account does not have billing enabled.

@pablo.perez Aggregate has reached end-of-life status is and no longer being updated or supported. See Aggregate is no longer being updated for more. I'd encourage you to switch to Central.

Thanks for the support. I actually created the survey though ODK central. Attached a screenshot. Is there something else to check?

I bet your XLSForm has a submission_url in the settings sheet that is overriding the server settings in Collect. Remove that submission_url, update your form in Central, and it should all work.

1 Like

Thanks @yanokwa ! I deleted the url, updated the form and it worked. So lucky to have your support! I have been on the screen for hours!

I got this in the results. Is it normal that the data preview is encripted?

1 Like

You've probably enabled (self-managed) encrypted forms by adding a public_key in your settings sheet.

1 Like

Thanks, didn't know what exactly went wrong at the end. I changed some settings in the XLS, uploaded it again and worked. Billion thanks for your support @yanokwa !