Error in ODK Collect while editing : Attempt to invoke virtual method on a null object reference

1. What is the problem? Be very detailed.
Error when trying to edit saved form.

2. What app or server are you using and on what device and operating system? Include version numbers.
ODK Collect v2021.2.4 hosted in KoboToolBox at multiple Android devices.

3. What have you tried to fix the problem?
Removed fields inside repeat groups that use calculation, repeat_count, choice_filter and fields linked to another field value with ${ } structure.

4. What steps can we take to reproduce the problem?
First save a form that has a repeat group inside another repeat group then try to edit the values in any of the repeat groups.

5. Anything else we should know or have? If you have a test form or screenshots or logs, attach below.

1 Like

Hi @rafaelsnv
We're glad you're here. When you get a chance, please introduce yourself on this forum thread.

Could you attach your form here so that we can reproduce the issue?

Hello @Grzesiek2010 can i send the form to you in private?


I think the problem is the same like here: Error in ODK Collect: Attempt to invoke virtual method '' on a null object reference

but I can't be a 100% sure because the form you shared with me does not contain some choices and i can't convert it.
Please share the correct version with mes so that I can confirm if it's the same bug.

Hello @Grzesiek2010 it seems to be the same error, however as far as I could understand the error cited by @Chonticha occurs when trying to view a form already sent, in my case the error happens when trying to edit a saved form.

I sent you a previous version of the form, please check your e-mail.

I also noticed that the same error occurs in a later version of the ones I sent you, in which there is no repeating group within another, in this case there is only one repeating group.

I have sent in a separate e-mail this version of the form and also a step-by-step so that you can reproduce the error on your device.

I will be off till September 13th starting tomorrow so I'll get back to it then.

I received your email with a detailed description step by step how to reproduce the issue. The root cause is the same like in case of Error in ODK Collect: Attempt to invoke virtual method '' on a null object reference
We are close to fixing the issue and it will be a part of next release.

Thanks for reporting it!