Error in odk collect

I get the following errors in my LOGCAT window when I run the app. The app is also not giving correct output.

  1. E/ctxmgr: [SyncServerInterestRecordsOperation]Failed WriteInterestRecord: network status=-1
    E/ctxmgr: [NetworkUtil]No active synchronizable contexts.

  2. E/Auth: [GoogleAccountDataServiceImpl] getToken() -> BAD_AUTHENTICATION. Account: ,
    App:, Service: oauth2:
    gep: Long live credential not available.

  3. E/ctxmgr: [BaseServerTask]Server task (WriteInterestRecordTask) got error statusCode=-1. Unable to obtain auth token - is the device online?

I'd love to help, but your post does not contain enough information for me to answer your question. In general, the best way to get help is to fill out the questions in the pre-filled template that you get when you create a support post. So, with that in mind, can you answer these questions?

  1. What ODK Collect version are you using? And on what device and operating system version?
  2. What steps can we take to reproduce the problem?
  3. What you have you tried to fix the problem?
  4. Anything else we should know or have? If you have a test form or screenshots, please attach.

I am running my app in an android based smartphone whose API level is 23 (MARSHMALLOW).

I have a login page at the first as..

In the menu page attached above, if "fill blank form" button is clicked, it should navigate to the below attached page (which is basically a data entry form).

I have named this form as activity_data_entry.xml and its corresponding java page is

I have called intent to this page under onclickListener.

But when I run the app, and when "fill blank form" button is clicked, the control goes back to the LOGIN PAGE which is present at the very beginning , instead of the data entry form

the file below contains the code for mainmenuActivityMAINMENUACTIVITY.txt (28.5 KB)


It's not an error in ODK Collect it's an error in your fork which works in different way. Unfortunately, we can't help you.