Error: Max value is 14

1. What is the issue? Please be detailed.

When i convert an excel form in the XLSForm Online v2.x
I get an error :Error: Max value is 14

2. What steps can we take to reproduce this issue?

I have attched the sheet

3. What have you tried to fix the issue?

I have check the sheet for error and taken out newly added questions.

4. Upload any test forms, screenshots, or logs below.

Waypoint-FormV3.xlsx (35.6 KB)

Hi @Wildscapes

On row 11, you have increment=true() in the required field (Column E) which is a wrong value. Please note you also have a lot of duplicate names in your Choice lists, you have to fix these before you can validate the form e.g PondArea and The name column for the 'Macrophytes' choice list contains these duplicates: '0.8', '0.85', '0.9', '0.95'. Duplicate names will be impossible to identify in analysis unless a previous value in a cascading select differentiates them. If this is intentional, you can set the allow_choice_duplicates setting to 'yes'. Learn more:

Thank you @Ronald_Munjoma,

I will take a look thank you for the guidence.

Much appricated


Hi @Ronald_Munjoma,

I have tried to allow_choice_duplicates did not work, I also even tried to delete the HSI section and the counter section of the form and the same error message occurs.

Have not got a clue what wrong with this thing

Thanks for you help away


I have got it to work using XLSForm Online v1.x

Still showing the same error message in XLSForm Online v2.x

so not sure what the issue was !

What error are you seeing now? Is it still Max value is 14? If so please fix that required column as @Ronald_Munjoma said. If it's something else please upload your updated xls form.


I still get an error when using v2 to convert. But V1 works fine. Not sure if I am missing something obvious
Waypoint-EEv02.xlsx (47.8 KB)

What tool did you use to build that xls file? Excel, Google Sheets or maybe something else? I'm asking because if I take your original file and try to convert it I get the same error but if I just open it and save again (without adding any changes) using Microsoft Excel format it fixes the issue so I guess it's a characters formatting issues or something like that.

I use a combination of google sheets and excel ( Microsoft 365 version) so sometimes it is also online in excel or Google Sheets on a phone or tablet or on a desktop PC.

So it may be a difference in online vs desktop versions?

Kind Regards

It's rather a wrong format used to save your file I guess. Please try to open it again in your tool and save as using Microsoft Excel format (xlsx) and let us know if it solves your problem.

1 Like